dev-embedded/simulavr: Fix cmake functions
[shuber-gentoo-overlay.git] / dev-util / edb / edb-0.9.18.ebuild
1 # Stolen from gentoo portage
2
3 inherit eutils multilib
4
5 DESCRIPTION="EDB \"Evan's Debugger\" (OllyDbg workalike for Linux)"
6 HOMEPAGE="http://www.codef00.com/projects#debugger"
7 SRC_URI="http://www.codef00.com/projects/debugger-${PV}.tgz"
8 LICENSE="GPL-2"
9 SLOT="0"
10 KEYWORDS="~x86 ~amd64"
11 IUSE=""
12 RESTRICT="strip mirror"
13
14 DEPEND="
15 >=x11-libs/qt-core-4.5.0
16 >=x11-libs/qt-gui-4.5.0
17 >=dev-libs/boost-1.35.0"
18
19 RDEPEND="${DEPEND}"
20 S="${WORKDIR}/debugger"
21
22 src_compile() {
23 qmake -makefile DEFAULT_PLUGIN_PATH="/usr/$(get_libdir)/edb/" || dir "qmake failed"
24 emake || die "emake failed"
25 }
26
27 src_install() {
28 make INSTALL_ROOT=${D}/usr/ install
29 dodoc CHANGELOG README README.plugins
30 doman edb.1
31 }
32
33 pkg_postinst() {
34 einfo "Note: EBD's plugins are installed by default into /usr/$(get_libdir)/edb."
35 einfo "If you have previously used EDB and have it set to look in a"
36 einfo "different directory, then you will need to adjust this. Also"
37 einfo "EDB looks for plugins in the current working directory as well"
38 einfo "as the directory specified in the options, so that unpriviledged"
39 einfo "users can use plugins not installed system wide."
40 }