app-misc/khard: Add 0.16.1 and fix 0.15.1
authorStefan Huber <shuber@sthu.org>
Fri, 8 May 2020 07:44:27 +0000 (09:44 +0200)
committerStefan Huber <shuber@sthu.org>
Fri, 8 May 2020 07:44:27 +0000 (09:44 +0200)
Enable python-3.7 for khard-0.15.1 and add khard-0.16.1

app-misc/khard/Manifest
app-misc/khard/khard-0.15.1.ebuild
app-misc/khard/khard-0.16.1.ebuild [new file with mode: 0644]

index 78dc023dc3f7e1a95eb8b08d0ec112d38e235bde..50e231017567193479934b09f2539373ca30e192 100644 (file)
@@ -1,2 +1,4 @@
 DIST khard-0.15.1.tar.gz 5099734 BLAKE2B 80ee37a0a33b1813ba9b567e3ca8a1ed81e55f608e032c619a46da2507cae1074bbc8b3fc06a86837e0ea794f382f327e5e11055f32159230533e51e8e89b168 SHA512 64ba1acf7e4046cd2e93034eb6e56fa38390993121880109a83411ef10839272b63e32c84efd9508230a93aed2b9a965f8333ed32344204f179ada936d9cce48
-EBUILD khard-0.15.1.ebuild 1160 BLAKE2B 3f35e34b09e0fcb3945772c0db37acfbc3654554ce01b51455ae9dfa4aa652d9b28c67517735e9dbc338c38a7ab9791a1f986860ce8818c7b776e92f88856d7c SHA512 b9a90448f96291407f21765c6c2bc04feef3533227d06b9ffb383597eec7024347aed9e18b7fd33acf1e970c44f720154b2a2cf8dc202d916934ba04ba616d9c
+DIST khard-0.16.1.tar.gz 626967 BLAKE2B b541bb314cc61da3013140e5be899402b817a0f890f046901843342bc1aa0be4eadb7b4e5942cdf702f27d91fc8a06005f43a59de155023d734046a49036b5f0 SHA512 617959667807e3108e4e73d8c9600da80d09daededdffcb0025941bff8f6ed3fc12f02dd2e0f39d1dc9cad125bf386308ed311e59ea5fa366fa9979ebe10aa62
+EBUILD khard-0.15.1.ebuild 1162 BLAKE2B f65fdc958f5df4240a65847a532a4e22d656942d8caa99ef9d6d107b45d3a8cec66bdffae120701c933e6f04f2de4bc729f8754dc9995c5ad82cb07f96dde65b SHA512 7b10f98b2c63dc594964a04081ae0da6cdd8e3f8bce13da9e2607aaff22f9dd3917f25e46cc7c17bcec8d1a726a51abf16d27cf3cb0dd81f21886b10bf336afb
+EBUILD khard-0.16.1.ebuild 1228 BLAKE2B cd63fab193bd439c92d24ddf7c62b751544bc273203f4d0869c03167f7c4470a5e769cccf65b1b2a14dff999b5297bee5684f69c2abb0a0c2dc55e18e091f83b SHA512 8028216eb308c63d3cbbc8889929992f0b28940badaa06a1577fe6d7e6fdde5ac3fd80216ab29434b55d3383c8ec2aac6d1e0f6a1c9b68d654101d3dbfc16a65
index aaa0b86fb01cebb6f09c80b37e599ca89044d2aa..d7cdda6adb6ab25a1f21bfb22c921ed85ad95779 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_{5,6,7} )
 inherit distutils-r1
 DESCRIPTION="Console CardDAV client"
 HOMEPAGE="https://github.com/scheibler/khard"
diff --git a/app-misc/khard/khard-0.16.1.ebuild b/app-misc/khard/khard-0.16.1.ebuild
new file mode 100644 (file)
index 0000000..3c0eb8a
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Console CardDAV client"
+HOMEPAGE="https://github.com/scheibler/khard"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test zsh-completion"
+RESTRICT="!test? ( test )"
+
+if [ "${PV}" == "9999" ]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/scheibler/khard"
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="amd64 ~arm64 ~x86"
+fi
+
+RDEPEND="
+       dev-python/atomicwrites[${PYTHON_USEDEP}]
+       dev-python/configobj[${PYTHON_USEDEP}]
+       dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+       dev-python/unidecode[${PYTHON_USEDEP}]
+       >dev-python/vobject-0.9.3[${PYTHON_USEDEP}]
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+       )
+"
+# vobject-0.9.3 breaks khard, see
+# https://github.com/scheibler/khard/issues/87
+# https://github.com/eventable/vobject/issues/39
+
+DOCS=( CHANGES README.md doc/source/examples/khard.conf.example )
+
+src_install() {
+       distutils-r1_src_install
+
+       if use zsh-completion; then
+               insinto /usr/share/zsh/site-functions
+               doins misc/zsh/_khard
+       fi
+}
+
+python_test() {
+       esetup.py test
+}