Add LEDA ebuild
authorStefan Huber <shuber@sthu.org>
Mon, 6 May 2013 12:29:09 +0000 (14:29 +0200)
committerStefan Huber <shuber@sthu.org>
Mon, 6 May 2013 12:29:09 +0000 (14:29 +0200)
dev-libs/leda-free/Manifest [new file with mode: 0644]
dev-libs/leda-free/leda-free-6.3.ebuild [new file with mode: 0644]
licenses/LEDA-free [new file with mode: 0644]

diff --git a/dev-libs/leda-free/Manifest b/dev-libs/leda-free/Manifest
new file mode 100644 (file)
index 0000000..3c79c80
--- /dev/null
@@ -0,0 +1,2 @@
+DIST LEDA-6.3-free-fedora-core-8-64-g++-4.1.2.tar.gz 7832698 SHA256 2966b95a9ef1f181c4a6140f6311ad9b46bcced881a2d37293e35ff89a1b899b SHA512 021bdd7b0357fd6d54d5ce25a5339067552b2566ec5dd11e619824fab7be32afa66b951cb5f78a8359e15887e9cabc7d3fd42e092586afa9a25b4d39f3e0099f WHIRLPOOL ad34a4948cdfba70873934ecddc070ec52db814843d5568ffc0dfded075a94fc171f6ab8b998864190278d1da30bf7f6b12108652b5f55f0802fdd4109ab86ba
+EBUILD leda-free-6.3.ebuild 685 SHA256 9f7382941333fe42f9e6602c04ca3d6d89b1c7dd3c7849f7020633ff0e014a85 SHA512 9fc3de3f3ba2e8d7806b0d3cafc8b00b35179fa998de1f81cd35b68ed26e4689c7c9c02d0b3f9c706a4e799299a0da55284fd331f908f9863549c047f3d017ec WHIRLPOOL 41bfe7212a39af63a7f86b9b0e47079a9bc6333d7426cb57376dbd3fb8dc2dbe00e9cba4d5f0b86215235166dc4462c02ac31a5336e6e6bff4d04917fda3c8b4
diff --git a/dev-libs/leda-free/leda-free-6.3.ebuild b/dev-libs/leda-free/leda-free-6.3.ebuild
new file mode 100644 (file)
index 0000000..f24b15e
--- /dev/null
@@ -0,0 +1,42 @@
+EAPI=3
+
+UNPACKDIR="LEDA-${PV}-free-fedora-core-8-64-g++-4.1.2"
+DESCRIPTION="Library of efficient data types and algorithms."
+HOMEPAGE="http://www.algorithmic-solutions.com/leda/index.htm"
+SRC_URI="http://www.algorithmic-solutions.info/free/Packages/${UNPACKDIR}.tar.gz"
+
+LICENSE="LEDA-free"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${UNPACKDIR}"
+
+
+src_unpack() {
+       gunzip -c ${DISTDIR}/${UNPACKDIR}.tar.gz | gunzip -c | tar -x -f -
+}
+
+src_compile() {
+       return
+}
+
+src_install() {
+       dolib libleda.a
+       dolib libleda.so
+
+       dodoc Readme.txt
+       dodoc license.txt
+       dodoc CHANGES
+       dodoc FIXES
+
+       insinto /usr/include/
+       doins -r incl/LEDA
+}
+
+
+
+
diff --git a/licenses/LEDA-free b/licenses/LEDA-free
new file mode 100644 (file)
index 0000000..27284ed
--- /dev/null
@@ -0,0 +1,25 @@
+
+You are installing LEDA, The Platform for Combinatorial and Geometric
+Computing.
+                                                                 
+    FOR ANY USE OF THIS SOFTWARE A LICENSE IS REQUIRED. 
+    YOU ARE BREAKING A LAW WHEN USING LEDA WITHOUT 
+    OWNING A LICENSE.                   
+
+These terms are valid for all LEDA versions following version 3.0
+For more information about the license terms please contact      
+                                                                 
+
+                 Algorithmic Solutions Software GmbH
+                 Schuetzenstrasse 3 - 5
+                 66123 Saarbruecken 
+                 Germany
+                 http:  www.algorithmic-solutions.com
+                 email: contact@algorithmic-solutions.com
+                 phone: +49 681 87647-0
+                 fax:   +49 681 87647-29
+
+You are allowed to continue with the installation of LEDA only if you are 
+owner of a valid license.
+Otherwise, you must stop the installation now.
+