add pycarddav-0.5.1
authorStefan Huber <shuber@sthu.org>
Sun, 10 Nov 2013 17:57:50 +0000 (18:57 +0100)
committerStefan Huber <shuber@sthu.org>
Sun, 10 Nov 2013 17:57:50 +0000 (18:57 +0100)
app-misc/pycarddav/Manifest [new file with mode: 0644]
app-misc/pycarddav/pycarddav-0.5.1.ebuild [new file with mode: 0644]

diff --git a/app-misc/pycarddav/Manifest b/app-misc/pycarddav/Manifest
new file mode 100644 (file)
index 0000000..fea89ef
--- /dev/null
@@ -0,0 +1,2 @@
+DIST pyCardDAV-0.5.1.tar.gz 31263 SHA256 d68128eb873c79ae6f43ba5672c7d4a3b51ea5714360f395cb0eb44ed837cddd SHA512 45e719dce9123aa39382d5da61e18fcc5adeae178ac188f1e393e5736ac33564227ff6ef289d628649d251f0835bea1b75f370fc9f26b5217e88585f9630a8ec WHIRLPOOL 7800f3382cf3727f8466df06c88bfe70aea7d8ffaac20fa79414b69b699572c477acf5272eab123290130385684ac95e28879e21141da2159559b9496cb25fcc
+EBUILD pycarddav-0.5.1.ebuild 1052 SHA256 b0e10af41b0816a7b27fa407a320df76bfda17bc456029bc614afa9cbba12b69 SHA512 851474ef74a4842df539c0b325148b4bbf683c42d84845db2ca94327c7e824a4bb733b30ded7ed89e8ab2e1624b9456988e21d21aaded3e7c2334868d7fad25c WHIRLPOOL 7c3bf5c5f96c14dae0a54351aad89fad7e4fe77a976b7ea812e0a6c793f25fb738930ba3dd3234ceaa2c34f51d9de4faaf5c97e71b9f7c221f177a0d57b61a62
diff --git a/app-misc/pycarddav/pycarddav-0.5.1.ebuild b/app-misc/pycarddav/pycarddav-0.5.1.ebuild
new file mode 100644 (file)
index 0000000..a4073c9
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_USE_WITH="sqlite"
+
+inherit distutils-r1
+
+MY_PN=pyCardDAV
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="pyCardDAV is a simple to use CardDAV CLI client with mutt
+support."
+HOMEPAGE="http://lostpackets.de/pycarddav/"
+SRC_URI="https://lostpackets.de/pycarddav/downloads/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/lxml
+        dev-python/requests
+        dev-python/urwid
+        dev-python/vobject
+        dev-python/pyxdg
+        virtual/python-argparse"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+EXAMPLES=( pycard.conf.sample )
+
+pkg_postinst() {
+    ewarn "Copy and edit the supplied pycard.conf.sample file"
+    ewarn "(default location is ~/.config/pycard/pycard.conf)."
+    ewarn "Beware that only you can access this file,"
+    ewarn "if you have untrusted users on your machine,"
+    ewarn "since the password is stored in cleartext."
+}