Add dev-db/sqlite3-pcre
authorStefan Huber <shuber@sthu.org>
Mon, 20 Jan 2014 17:46:22 +0000 (18:46 +0100)
committerStefan Huber <shuber@sthu.org>
Mon, 20 Jan 2014 17:46:22 +0000 (18:46 +0100)
dev-db/sqlite3-pcre/files/Makefile [new file with mode: 0644]
dev-db/sqlite3-pcre/sqlite3-pcre-20070120.ebuild [new file with mode: 0644]

diff --git a/dev-db/sqlite3-pcre/files/Makefile b/dev-db/sqlite3-pcre/files/Makefile
new file mode 100644 (file)
index 0000000..78272a6
--- /dev/null
@@ -0,0 +1,16 @@
+CC=cc
+INSTALL=install
+CFLAGS=$(shell pkg-config --cflags sqlite3 libpcre) -fPIC
+LIBS=$(shell pkg-config --libs libpcre)
+prefix=/usr
+
+.PHONY : install clean
+
+pcre.so : pcre.c
+       ${CC} -shared -o $@ ${CFLAGS} -W -Werror pcre.c ${LIBS} -Wl,-z,defs
+
+install : pcre.so
+       ${INSTALL} -pD -m755 pcre.so ${DESTDIR}${prefix}/lib/sqlite3/pcre.so
+
+clean :
+       -rm -f pcre.so
diff --git a/dev-db/sqlite3-pcre/sqlite3-pcre-20070120.ebuild b/dev-db/sqlite3-pcre/sqlite3-pcre-20070120.ebuild
new file mode 100644 (file)
index 0000000..c90cb17
--- /dev/null
@@ -0,0 +1,22 @@
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Perl-compatible regular expression support for the SQLite"
+HOMEPAGE="http://git.altlinux.org/people/at/packages/?p=sqlite3-pcre.git"
+SRC_URI="https://launchpad.net/ubuntu/+archive/primary/+files/sqlite3-pcre_0~git20070120091816+4229ecc.orig.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="dev-db/sqlite:3
+               dev-libs/libpcre"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+       cp "${FILESDIR}/Makefile" "${S}/"
+}