media-gfx/ipe-tools: Add ipe-tools-7.2.13.1
[shuber-gentoo-overlay.git] / media-gfx / svgtoipe / svgtoipe-9999.ebuild
index 2cd67ea38f4e4638e895f651f00a30f1a94c39a4..ad129adeb83b863204646aa027dae914d64cc542 100644 (file)
@@ -1,9 +1,10 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI=2
+EAPI=6
 
 
-inherit git-2
+PYTHON_COMPAT=( python3_{6,7} )
+inherit git-r3 python-single-r1
 
 DESCRIPTION="Converts SVG files to Ipe xml files"
 HOMEPAGE="https://github.com/otfried/ipe-tools/tree/master/figtoipe"
 
 DESCRIPTION="Converts SVG files to Ipe xml files"
 HOMEPAGE="https://github.com/otfried/ipe-tools/tree/master/figtoipe"
@@ -15,17 +16,20 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE=""
 
 KEYWORDS="~amd64 ~x86"
 IUSE=""
 
-DEPEND="|| ( dev-lang/python:2.6[xml] dev-lang/python:2.7[xml] )
-               virtual/python-imaging"
+DEPEND="dev-lang/python[xml]
+               !media-gfx/ipe-tools"
 RDEPEND="${DEPEND}"
 
 RDEPEND="${DEPEND}"
 
-BASEDIR="${WORKDIR}/${P}/ipe5toxml"
+BASEDIR="${WORKDIR}/${P}/${PN}"
 
 src_install() {
        cd ${BASEDIR}
 
 src_install() {
        cd ${BASEDIR}
-       mv svgtoipe.py svgtoipe
+       python_fix_shebang .
+
+       mv ${PN}.py ${PN}
        exeinto /usr/bin/
        exeinto /usr/bin/
-       doexe svgtoipe
+       doexe ${PN}
+       doman ${PN}.1
 }
 
 
 }