ad129adeb83b863204646aa027dae914d64cc542
[shuber-gentoo-overlay.git] / media-gfx / svgtoipe / svgtoipe-9999.ebuild
1 # Distributed under the terms of the GNU General Public License v2
2 # $Header: $
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{6,7} )
7 inherit git-r3 python-single-r1
8
9 DESCRIPTION="Converts SVG files to Ipe xml files"
10 HOMEPAGE="https://github.com/otfried/ipe-tools/tree/master/figtoipe"
11 EGIT_REPO_URI="https://github.com/otfried/ipe-tools.git"
12 SRC_URI=""
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="dev-lang/python[xml]
20 !media-gfx/ipe-tools"
21 RDEPEND="${DEPEND}"
22
23 BASEDIR="${WORKDIR}/${P}/${PN}"
24
25 src_install() {
26 cd ${BASEDIR}
27 python_fix_shebang .
28
29 mv ${PN}.py ${PN}
30 exeinto /usr/bin/
31 doexe ${PN}
32 doman ${PN}.1
33 }
34
35