Move dev-python/imaging to virtual/python-imaging
[shuber-gentoo-overlay.git] / sci-geosciences / gmapcatcher / gmapcatcher-0.8.0.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit base eutils python
8
9 PYTHON_DEPEND="2"
10
11 DESCRIPTION="An offline map viewer for Google Maps, OpenStreetMap and others."
12 HOMEPAGE="http://code.google.com/p/gmapcatcher/"
13 SRC_URI="http://gmapcatcher.googlecode.com/files/mapcatcher_${PV}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~x86 ~amd64"
18 RESTRICT="mirror"
19 IUSE=""
20
21 DEPEND="|| ( dev-lang/python:2.6 dev-lang/python:2.7 )
22 x11-libs/gtk+
23 dev-python/pygtk
24 dev-python/pygobject
25 dev-python/pycairo
26 virtual/python-imaging"
27 RDEPEND="${DEPEND}"
28
29 S="${WORKDIR}/mapcatcher-${PV}"
30
31
32 pkg_setup() {
33 python_set_active_version 2
34 python_pkg_setup
35 }
36
37 src_prepare() {
38 python_convert_shebangs -r 2 .
39 }
40
41 src_install() {
42 domenu gmapcatcher.desktop
43 newicon images/map.png mapcatcher.png
44 doman man/*
45 dodoc README
46
47 insinto $(python_get_sitedir)
48 doins -r gmapcatcher || die
49
50 exeinto /usr/bin/
51 doexe mapcatcher || die
52 doexe mapdownloader || die
53 doexe mapexport.py || die
54 }
55
56
57