c8fe6f469de6c09ec42111f510e0ef9fd10b9e45
[shuber-gentoo-overlay.git] / media-gfx / pdftoipe / pdftoipe-20110916-r1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit eutils
8
9 DESCRIPTION="Converts pdf files to Ipe xml files"
10 HOMEPAGE="http://ipe7.sourceforge.net/"
11 PEXT="${P}-src"
12 SRC_URI="http://sourceforge.net/projects/ipe7/files%2Ftools%2F${PEXT}.tar.gz/download
13 -> ${P}.tar.gz"
14
15
16 LICENSE="GPL-3"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 RESTRICT="mirror"
20 IUSE=""
21 S="${WORKDIR}/${PEXT}"
22
23 DEPEND="app-text/poppler
24 >=media-gfx/ipe-7.0.0"
25 RDEPEND="${DEPEND}"
26
27
28 src_prepare() {
29 epatch "${FILESDIR}"/poppler-0.18.patch || die
30 }
31
32 src_compile() {
33 emake || die
34 }
35
36 src_install() {
37 exeinto /usr/bin/
38 doexe $S/pdftoipe
39 doman $S/pdftoipe.1
40 dodoc $S/readme.txt
41 }
42
43