ipe-7.0.13 released
[shuber-gentoo-overlay.git] / media-gfx / ipe / ipe-7.0.13.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 inherit eutils toolchain-funcs qt4-r2
7
8 DESCRIPTION="A drawing editor which creates figures for inclusion in LaTeX documents and makes PDF presentations."
9 HOMEPAGE="http://ipe7.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/ipe7/ipe/${P}-src.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 RESTRICT="mirror"
16 # highprec: applies patch in order to write coordinates with higher precision
17 IUSE="seamonkey highprec"
18
19 DEPEND="
20 app-text/texlive-core
21 >=dev-lang/lua-5.1
22 >=media-libs/freetype-2.1.8
23 sys-libs/zlib
24 >=x11-libs/cairo-1.8.0
25 >=x11-libs/qt-core-4.5:4
26 >=x11-libs/qt-gui-4.5:4
27 "
28
29 RDEPEND="${DEPEND}
30 !seamonkey? ( || ( www-client/firefox
31 www-client/firefox-bin ) )
32 seamonkey? ( || ( www-client/seamonkey
33 www-client/seamonkey-bin ) )"
34
35 S=${S}/src
36
37 search_urw_fonts() {
38 local texmfdist="$(kpsewhich -var-value=TEXMFDIST)" # colon-separated list of paths
39 local urwdir=fonts/type1/urw # according to TeX directory structure
40 local IFS="${IFS}:" # add colon as field separator
41 for dir in ${texmfdist}; do
42 if [[ -d "${dir}/${urwdir}" ]]; then
43 URWFONTDIR="${dir}/${urwdir}"
44 return 0
45 fi
46 done
47
48 return 1
49 }
50
51 src_prepare() {
52 if use highprec; then
53 einfo "Adding patch for higher output precision"
54 epatch "${FILESDIR}"/${PN}-outputprecision.patch
55 fi
56 }
57
58 pkg_setup() {
59 if search_urw_fonts; then
60 einfo "URW fonts found in ${URWFONTDIR}."
61 else
62 ewarn "Could not find directory containing URW fonts. Ipe will not"
63 ewarn "function properly without them."
64 fi
65 }
66
67 src_compile() {
68 # Ipe's default browser is Firefox
69 local myconf
70 use seamonkey && myconf="IPEBROWSER=seamonkey"
71 # fix detection of lua
72 sed -i -e 's/lua5.1/lua/g' config.mak || die
73 # don't strip installed binaries
74 sed -i -e 's/install -s/install/' common.mak || die
75 # use moc instead of moc-qt4
76 sed -i -e 's/moc-qt4/moc/' config.mak || die
77
78 # -j1, since there are no deps in the Makefiles on libipe
79 emake -j1 CXX=$(tc-getCXX) $myconf IPEPREFIX="/usr" \
80 IPEDOCDIR="/usr/share/doc/${PF}" || die "emake failed"
81 }
82
83 src_install() {
84 emake install IPEPREFIX="/usr" IPEDOCDIR="/usr/share/doc/${PF}" \
85 INSTALL_ROOT="${D}" || die "emake install failed"
86 dodoc ../{news,readme}.txt || die
87 }