7ee593f3879630ef46102bbf261f358a2eaf7691
[shuber-gentoo-overlay.git] / media-gfx / figtoipe / figtoipe-9999.ebuild
1 # Distributed under the terms of the GNU General Public License v2
2 # $Header: $
3
4 EAPI=0
5
6 inherit git-2
7
8 DESCRIPTION="Converts FIG files (xfig) to XML files (Ipe)"
9 HOMEPAGE="https://github.com/otfried/ipe-tools/tree/master/figtoipe"
10 EGIT_REPO_URI="https://github.com/otfried/ipe-tools.git"
11 SRC_URI=""
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND=">=media-gfx/ipe-7.0.0"
19 RDEPEND="${DEPEND}"
20
21 BASEDIR="${WORKDIR}/${P}/figtoipe"
22
23 src_compile() {
24 cd ${BASEDIR}
25 emake
26 }
27
28 src_install() {
29 cd ${BASEDIR}
30 exeinto /usr/bin/
31 doexe figtoipe
32 doman figtoipe.1
33 }
34
35