media-gfx/ipe: Move to EAPI=7
[shuber-gentoo-overlay.git] / dev-ros / rqt_image_view / rqt_image_view-0.4.14.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 KEYWORDS="~amd64"
7 ROS_REPO_URI="https://github.com/ros-visualization/rqt_image_view"
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="GUI plugin for displaying images using image_transport"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18 dev-ros/cv_bridge[${PYTHON_USEDEP}]
19 media-libs/opencv:=
20 dev-ros/image_transport
21 dev-ros/rqt_gui[${PYTHON_USEDEP}]
22 >=dev-ros/rqt_gui_cpp-0.3
23 dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
24 dev-qt/qtwidgets:5
25 dev-libs/boost:=
26 dev-libs/console_bridge:=
27 "
28 DEPEND="${RDEPEND}"