media-gfx/ipe: Add ipe-7.2.11
[shuber-gentoo-overlay.git] / app-misc / v800_downloader / v800_downloader-6.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6 inherit eutils qmake-utils
7
8 DESCRIPTION="A tool o download sessions from the Polar M400/V800 watch"
9 HOMEPAGE="https://github.com/profanum429/v800_downloader"
10 SRC_URI="https://github.com/profanum429/${PN}/archive/Release${PV}%60.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="qt5"
16
17 DEPEND="
18 dev-qt/qtcore:5
19 dev-qt/qtgui:5
20 dev-qt/qtxml:5
21 sys-libs/zlib
22 virtual/libudev"
23 RDEPEND="${DEPEND}"
24 S=${WORKDIR}/${PN}-Release${PV}-
25
26 src_configure() {
27 ac_qmake="$(qt5_get_bindir)/qmake"
28 cd "${S}"
29 eqmake5 .
30 }
31
32 src_install() {
33 cd ${S}/release/
34 exeinto /usr/bin
35 doexe v800_downloader
36 }