ipe: Add ipe-7.2.2. and update SRC_URIs
[shuber-gentoo-overlay.git] / app-misc / pycarddav / pycarddav-0.7.0.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 PYTHON_COMPAT=( python{2_6,2_7} )
8 PYTHON_USE_WITH="sqlite"
9
10 inherit distutils-r1
11
12 MYP="pyCardDAV"
13
14 DESCRIPTION="pyCardDAV is a simple to use CardDAV CLI client with mutt
15 support."
16 HOMEPAGE="http://lostpackets.de/pycarddav/"
17 SRC_URI="https://lostpackets.de/pycarddav/downloads/${MYP}-${PV}.tar.gz"
18 S="${WORKDIR}/${MYP}-${PV}"
19
20 LICENSE="MIT"
21 KEYWORDS="~x86 ~amd64"
22 SLOT="0"
23 IUSE=""
24
25 DEPEND="dev-python/lxml
26 dev-python/requests
27 dev-python/urwid
28 dev-python/vobject
29 dev-python/pyxdg
30 dev-python/keyring"
31 RDEPEND="${DEPEND}"
32
33 EXAMPLES=( pycard.conf.sample )
34
35 pkg_postinst() {
36 ewarn "Copy and edit the supplied pycard.conf.sample file"
37 ewarn "(default location is ~/.config/pycard/pycard.conf)."
38 ewarn "Beware that only you can access this file,"
39 ewarn "if you have untrusted users on your machine,"
40 ewarn "since the password is stored in cleartext."
41 }