5ce228a7f9d1a4f6961255b09c4542d508b5619b
[shuber-gentoo-overlay.git] / app-misc / pycarddav / pycarddav-0.7.0.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 PYTHON_COMPAT=( python{2_6,2_7} )
8
9 inherit distutils-r1
10
11 MYP="pyCardDAV"
12
13 DESCRIPTION="pyCardDAV is a simple to use CardDAV CLI client with mutt
14 support."
15 HOMEPAGE="http://lostpackets.de/pycarddav/"
16 SRC_URI="https://lostpackets.de/pycarddav/downloads/${MYP}-${PV}.tar.gz"
17 S="${WORKDIR}/${MYP}-${PV}"
18
19 LICENSE="MIT"
20 KEYWORDS="~x86 ~amd64"
21 SLOT="0"
22 IUSE=""
23
24 DEPEND="dev-python/lxml
25 dev-python/requests
26 dev-python/urwid
27 dev-python/vobject
28 dev-python/pyxdg
29 dev-python/keyring"
30 RDEPEND="${DEPEND}"
31
32 EXAMPLES=( pycard.conf.sample )
33
34
35 src_prepare() {
36 epatch ${FILESDIR}/utf8-decode.patch
37 }
38
39 pkg_postinst() {
40 ewarn "Copy and edit the supplied pycard.conf.sample file"
41 ewarn "(default location is ~/.config/pycard/pycard.conf)."
42 ewarn "Beware that only you can access this file,"
43 ewarn "if you have untrusted users on your machine,"
44 ewarn "since the password is stored in cleartext."
45 }