Add x11-apps/inputplug
[shuber-gentoo-overlay.git] / app-misc / pycarddav / pycarddav-0.5.1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 PYTHON_COMPAT=( python{2_6,2_7} )
8 PYTHON_USE_WITH="sqlite"
9
10 inherit distutils-r1
11
12 MY_PN=pyCardDAV
13 MY_P=${MY_PN}-${PV}
14
15 DESCRIPTION="pyCardDAV is a simple to use CardDAV CLI client with mutt
16 support."
17 HOMEPAGE="http://lostpackets.de/pycarddav/"
18 SRC_URI="https://lostpackets.de/pycarddav/downloads/${MY_P}.tar.gz"
19
20 LICENSE="MIT"
21 KEYWORDS="~x86 ~amd64"
22 SLOT="0"
23 IUSE=""
24
25 DEPEND="dev-python/lxml
26 dev-python/requests
27 dev-python/urwid
28 dev-python/vobject
29 dev-python/pyxdg
30 virtual/python-argparse"
31 RDEPEND="${DEPEND}"
32
33 S="${WORKDIR}/${MY_P}"
34
35 EXAMPLES=( pycard.conf.sample )
36
37 pkg_postinst() {
38 ewarn "Copy and edit the supplied pycard.conf.sample file"
39 ewarn "(default location is ~/.config/pycard/pycard.conf)."
40 ewarn "Beware that only you can access this file,"
41 ewarn "if you have untrusted users on your machine,"
42 ewarn "since the password is stored in cleartext."
43 }