Imported new upstream release for gpgdir.
[pgp-tools.git] / gpgdir / packaging / gpgdir-nodeps.spec
1 %define name gpgdir
2 %define version 1.9.5
3 %define release 1
4 %define gpgdirlibdir %_libdir/%name
5
6 Summary: Gpgdir recursively encrypts/decrypts directories with GnuPG.
7 Name: %name
8 Version: %version
9 Release: %release
10 License: GPL
11 Group: Applications/Cryptography
12 Url: http://www.cipherdyne.org/gpgdir/
13 Source: %name-%version.tar.gz
14 BuildRoot: %_tmppath/%{name}-buildroot
15 #Prereq: rpm-helper
16
17 %description
18 gpgdir is a perl script that uses the CPAN GnuPG::Interface perl module to encrypt
19 and decrypt directories using a gpg key specified in ~/.gpgdirrc. gpgdir recursively
20 descends through a directory in order to make sure it encrypts or decrypts every file
21 in a directory and all of its subdirectories. By default the mtime and atime values
22 of all files will be preserved upon encryption and decryption (this can be disabled
23 with the --no-preserve-times option). Note that in --encrypt mode, gpgdir will
24 delete the original files that it successfully encrypts (unless the --no-delete
25 option is given). However, upon startup gpgdir first asks for a the decryption pass-
26 word to be sure that a dummy file can successfully be encrypted and decrypted. The
27 initial test can be disabled with the --skip-test option so that a directory can eas-
28 ily be encrypted without having to also specify a password (this is consistent with
29 gpg behavior). Also, note that gpgdir is careful not encrypt hidden files and direc-
30 tories. After all, you probably don't want your ~/.gnupg directory or ~/.bashrc file
31 to be encrypted.
32
33 %prep
34 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
35
36 %setup -q
37
38 %build
39
40 %install
41
42 install -m 755 gpgdir $RPM_BUILD_ROOT%_bindir/
43 install -m 644 gpgdir.1 $RPM_BUILD_ROOT%{_mandir}/man1/
44
45 %clean
46 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
47
48 %pre
49
50 %post
51
52 %preun
53
54 %files
55 %defattr(-,root,root)
56 %_bindir/*
57 %{_mandir}/man1/*
58 %_libdir/%name
59
60 %changelog
61 * Sat Sep 05 2009 Michael Rash <mbr@cipherdyne.org>
62 - gpgdir-1.9.5 release
63
64 * Thu Feb 12 2009 Michael Rash <mbr@cipherdyne.org>
65 - gpgdir-1.9.4 release
66
67 * Wed Nov 11 2008 Michael Rash <mbr@cipherdyne.org>
68 - gpgdir-1.9.3 release
69
70 * Sun Aug 31 2008 Michael Rash <mbr@cipherdyne.org>
71 - This spec file omits installing any perl module dependencies.
72 - gpgdir-1.9.2 release
73
74 * Sat Jun 07 2008 Michael Rash <mbr@cipherdyne.org>
75 - gpgdir-1.9.1 release
76
77 * Sat May 31 2008 Michael Rash <mbr@cipherdyne.org>
78 - gpgdir-1.9 release
79
80 * Mon Feb 18 2008 Michael Rash <mbr@cipherdyne.org>
81 - gpgdir-1.8 release
82
83 * Mon Feb 18 2008 Michael Rash <mbr@cipherdyne.org>
84 - gpgdir-1.7 release
85
86 * Sun Feb 17 2008 Michael Rash <mbr@cipherdyne.org>
87 - gpgdir-1.6 release
88
89 * Fri Aug 31 2007 Michael Rash <mbr@cipherdyne.org>
90 - gpgdir-1.5 release
91
92 * Sat Jul 20 2007 Michael Rash <mbr@cipherdyne.org>
93 - gpgdir-1.4 release
94
95 * Sat Jun 09 2007 Michael Rash <mbr@cipherdyne.org>
96 - gpgdir-1.3 release
97
98 * Mon May 28 2007 Michael Rash <mbr@cipherdyne.org>
99 - gpgdir-1.2 release
100
101 * Mon May 21 2007 Michael Rash <mbr@cipherdyne.org>
102 - gpgdir-1.1 release
103
104 * Sun Sep 17 2006 Michael Rash <mbr@cipherdyne.org>
105 - gpgdir-1.0.3 release (1.0.2 was skipped accidentally).
106
107 * Sat Sep 16 2006 Michael Rash <mbr@cipherdyne.org>
108 - Added x86_64 RPM.
109 - Removed iptables as a prerequisite.
110 - gpgdir-1.0.1 release
111
112 * Wed Sep 13 2006 Michael Rash <mbr@cipherdyne.org>
113 - gpgdir-1.0 release
114
115 * Thu Sep 09 2006 Michael Rash <mbr@cipherdyne.org>
116 - Initial RPM release of gpgdir-0.9.9