Add app-misc/pycarddav-0.7.0
authorStefan Huber <shuber@sthu.org>
Mon, 6 Apr 2015 16:26:03 +0000 (18:26 +0200)
committerStefan Huber <shuber@sthu.org>
Mon, 6 Apr 2015 16:26:03 +0000 (18:26 +0200)
app-misc/pycarddav/pycarddav-0.7.0.ebuild [new file with mode: 0644]

diff --git a/app-misc/pycarddav/pycarddav-0.7.0.ebuild b/app-misc/pycarddav/pycarddav-0.7.0.ebuild
new file mode 100644 (file)
index 0000000..dcc5d5b
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_USE_WITH="sqlite"
+
+inherit distutils-r1
+
+MYP="pyCardDAV"
+
+DESCRIPTION="pyCardDAV is a simple to use CardDAV CLI client with mutt
+support."
+HOMEPAGE="http://lostpackets.de/pycarddav/"
+SRC_URI="https://lostpackets.de/pycarddav/downloads/${MYP}-${PV}.tar.gz"
+S="${WORKDIR}/${MYP}-${PV}"
+
+LICENSE="MIT"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/lxml
+       dev-python/requests
+       dev-python/urwid
+       dev-python/vobject
+       dev-python/pyxdg
+       dev-python/keyring"
+RDEPEND="${DEPEND}"
+
+EXAMPLES=( pycard.conf.sample )
+
+pkg_postinst() {
+       ewarn "Copy and edit the supplied pycard.conf.sample file"
+       ewarn "(default location is ~/.config/pycard/pycard.conf)."
+       ewarn "Beware that only you can access this file,"
+       ewarn "if you have untrusted users on your machine,"
+       ewarn "since the password is stored in cleartext."
+}