add dev-util/edb
authorStefan Huber <shuber2@gmx.at>
Mon, 19 Dec 2011 09:25:32 +0000 (10:25 +0100)
committerStefan Huber <shuber2@gmx.at>
Mon, 19 Dec 2011 09:25:32 +0000 (10:25 +0100)
Ebuild taken from projects website

dev-util/edb/Manifest [new file with mode: 0644]
dev-util/edb/edb-0.9.17.ebuild [new file with mode: 0644]

diff --git a/dev-util/edb/Manifest b/dev-util/edb/Manifest
new file mode 100644 (file)
index 0000000..4169343
--- /dev/null
@@ -0,0 +1,2 @@
+DIST debugger-0.9.17.tgz 680055 RMD160 8cebbfff0e7d7af66544ba97c81c300ca9d26880 SHA1 6a0b2e869639d4b321ceef468b632a93058939fb SHA256 acd33e8babdaf56b1500576adf86c91363e071bc1b19a60037b2de72736ae87e
+EBUILD edb-0.9.17.ebuild 1228 RMD160 29f25f1b53b1568f17db111d9bcd15d05c6959d3 SHA1 0dfab1adf8be00098397f99c8503beb448dc4ae5 SHA256 fc7c3d1dca49e9b1cc05de4a2e69ed04467814701744507fda3bb7eb64568651
diff --git a/dev-util/edb/edb-0.9.17.ebuild b/dev-util/edb/edb-0.9.17.ebuild
new file mode 100644 (file)
index 0000000..a3afa1d
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils multilib
+
+DESCRIPTION="EDB \"Evan's Debugger\" (OllyDbg workalike for Linux)"
+HOMEPAGE="http://www.codef00.com/projects#debugger"
+SRC_URI="http://www.codef00.com/projects/debugger-${PV}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="strip mirror"
+
+DEPEND="
+       >=x11-libs/qt-core-4.5.0
+       >=x11-libs/qt-gui-4.5.0
+       >=dev-libs/boost-1.35.0"
+       
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/debugger"
+
+src_compile() {
+       qmake -makefile DEFAULT_PLUGIN_PATH="/usr/$(get_libdir)/edb/" || dir "qmake failed"
+       emake || die "emake failed"
+}
+
+src_install() {
+       make INSTALL_ROOT=${D}/usr/ install
+       dodoc CHANGELOG README README.plugins
+       doman edb.1
+}
+
+pkg_postinst() {
+       einfo "Note: EBD's plugins are installed by default into /usr/$(get_libdir)/edb."
+       einfo "If you have previously used EDB and have it set to look in a"
+       einfo "different directory, then you will need to adjust this. Also"
+       einfo "EDB looks for plugins in the current working directory as well"
+       einfo "as the directory specified in the options, so that unpriviledged"
+       einfo "users can use plugins not installed system wide."
+}