sci-libs/itk-4.4.2-r1: Add vtkglue use flag
authorStefan Huber <shuber@sthu.org>
Fri, 15 Nov 2013 21:45:49 +0000 (22:45 +0100)
committerStefan Huber <shuber@sthu.org>
Fri, 15 Nov 2013 23:23:38 +0000 (00:23 +0100)
Enable Module_ITKVtkGlue if vtkglue use flag is set. VtkGlue is used for
glueing an ITK pipeline and a VTK pipeline together.

sci-libs/itk/itk-4.4.2-r1.ebuild

index 542216b7e8a7434d8c6e2aaddd831eb9754a00cf..5671bb01758060eacc03e086d7a6838e03cc7ee2 100644 (file)
@@ -19,7 +19,7 @@ RESTRICT="primaryuri"
 LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug examples fftw itkv3compat python review sse2 test"
+IUSE="debug examples fftw itkv3compat python review sse2 test vtkglue"
 
 RDEPEND="
        sci-libs/hdf5[cxx]
@@ -28,6 +28,7 @@ RDEPEND="
        media-libs/tiff:0
        sys-libs/zlib
        fftw? ( sci-libs/fftw:3.0 )
+       vtkglue? ( sci-libs/vtk )
 "
 DEPEND="${RDEPEND}
        python? ( ${PYTHON_DEPS}
@@ -82,6 +83,11 @@ src_configure() {
                        -DITK_WRAP_complex_double=ON
                )
        fi
+       if use vtkglue; then
+               mycmakeargs+=(
+                       -DModule_ITKVtkGlue=ON
+               )
+       fi
        if use python; then
                mycmakeargs+=(
                        -DITK_WRAP_PYTHON=ON