svgtoipe: Fix shebang
authorStefan Huber <shuber@sthu.org>
Sun, 18 Mar 2018 12:42:37 +0000 (13:42 +0100)
committerStefan Huber <shuber@sthu.org>
Sun, 18 Mar 2018 12:42:37 +0000 (13:42 +0100)
media-gfx/svgtoipe/Manifest
media-gfx/svgtoipe/svgtoipe-9999.ebuild

index a1efb67d0ea761ffb133e562c2408fa45ad2fb57..7e200723bb0e063b73ec2eccf7f4dd2a63a0953e 100644 (file)
@@ -1 +1 @@
-EBUILD svgtoipe-9999.ebuild 570 BLAKE2B a8713cae8180595e63f29294c75be025da5dde8dee4a1b73db8a29bfe7a77acb67c9306652a28a6ac63a163d96d01ebaff758d10cf3d0e3aba1e2fe67c2125c6 SHA512 861c713fc44f00551d8dc86fadee93810ee504229f2c7fdb8db61e2f4f29eecfc48b14faa1697bafbebee2e458c5f168ff795276ae12cd02bd3308bd6ace629a
+EBUILD svgtoipe-9999.ebuild 639 BLAKE2B 354c13db93f3b88802e29150d4653d2586b15ca8807ec12b3567d4a2a6c77c278dee835f2a0d3e97269f46bd810214e94944dae6673ad4ddfc76b976504900c5 SHA512 be0a33a52b06a65476b272018d16325b16355465d5059da92bde6264d22a16bd6862dbd6e7abf868d579d89156cb0fcd4815addfa798e596e6e9675bd692bb78
index 358c973f05633ee4daded20676486d647b1b12c7..3a6c70679c839e1ab3a22e12c576c20b0ebbffbd 100644 (file)
@@ -1,9 +1,10 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI=2
+EAPI=6
 
 
-inherit git-2
+PYTHON_COMPAT=( python2_7 )
+inherit git-r3 python-single-r1
 
 DESCRIPTION="Converts SVG files to Ipe xml files"
 HOMEPAGE="https://github.com/otfried/ipe-tools/tree/master/figtoipe"
 
 DESCRIPTION="Converts SVG files to Ipe xml files"
 HOMEPAGE="https://github.com/otfried/ipe-tools/tree/master/figtoipe"
@@ -22,6 +23,8 @@ BASEDIR="${WORKDIR}/${P}/${PN}"
 
 src_install() {
        cd ${BASEDIR}
 
 src_install() {
        cd ${BASEDIR}
+       python_fix_shebang .
+
        mv ${PN}.py ${PN}
        exeinto /usr/bin/
        doexe ${PN}
        mv ${PN}.py ${PN}
        exeinto /usr/bin/
        doexe ${PN}