dev-python/vdirsyncer: Add 0.16.7-r1
authorStefan Huber <shuber@sthu.org>
Fri, 15 May 2020 17:59:24 +0000 (19:59 +0200)
committerStefan Huber <shuber@sthu.org>
Fri, 15 May 2020 17:59:24 +0000 (19:59 +0200)
It is a copy from portage but with py3.7 instead of py3.6.

dev-python/vdirsyncer/Manifest [new file with mode: 0644]
dev-python/vdirsyncer/metadata.xml [new file with mode: 0644]
dev-python/vdirsyncer/vdirsyncer-0.16.7-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/vdirsyncer/Manifest b/dev-python/vdirsyncer/Manifest
new file mode 100644 (file)
index 0000000..f5c99f7
--- /dev/null
@@ -0,0 +1,3 @@
+DIST vdirsyncer-0.16.7.tar.gz 112786 BLAKE2B 19b9ce6e3e9de0a626b9562b4d54b270c1532d93169fe2d872f15c6bf6e1ac94bc623c171e51e871082422116636b4945b58dd172cfca527a010906737f1b6a3 SHA512 218c6781139a9e979077308dc732756cc27ecb67966e4b52be31cb1ebf04d224443036102d5c4bad253b9dcf533939f0b72082166f0fe94e042a7e946b8fad0e
+EBUILD vdirsyncer-0.16.7-r1.ebuild 1504 BLAKE2B ba42c4b90595723bdc7c5eac2f351d1c308311cd909257770366001e1a98b8e55864aad4931de60abf237385c80d9b9dc1ee2a241ae174ba5d5a8cf9328956ff SHA512 d5453ec94c84e1904d05b54732c3de771b3006c9cf661bc755d192d41b179be591da57b1f65b11ba869d95b4c0b64472f6ca4d81d09ed35babfa15ae24562dac
+MISC metadata.xml 349 BLAKE2B 20ad2ded190f80b37283e6ef064168094e9edeec5ca6ba262e9e6d977bd28d1538056b21efa7fecc090b63424a23f87c54ec1e2e2dcd02a2f4c5ab7b4b82abe1 SHA512 5e2d7f27428065740bdee11e59053519c83054c19156f77ec03fc6e416ca44ea0b74178844ac8ef84d1993927bcf3ba0b80d84296a152a006681ed77e87ed14f
diff --git a/dev-python/vdirsyncer/metadata.xml b/dev-python/vdirsyncer/metadata.xml
new file mode 100644 (file)
index 0000000..161dede
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>amynka@gentoo.org</email>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">pimutils/vdirsyncer</remote-id>
+               <remote-id type="pypi">vdirsyncer</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.16.7-r1.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.16.7-r1.ebuild
new file mode 100644 (file)
index 0000000..6044421
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Synchronize calendars and contacts"
+HOMEPAGE="https://github.com/pimutils/vdirsyncer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/click-5.0[${PYTHON_USEDEP}]
+       >=dev-python/click-log-0.3.0[${PYTHON_USEDEP}]
+       <dev-python/click-log-0.4.0[${PYTHON_USEDEP}]
+       >=dev-python/click-threading-0.2[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
+       !=dev-python/requests-2.9.0[${PYTHON_USEDEP}]
+       >=dev-python/requests-toolbelt-0.4.0[${PYTHON_USEDEP}]
+       >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/setuptools_scm[${PYTHON_USEDEP}]
+       test? (
+               >=dev-python/hypothesis-3.1[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-localserver[${PYTHON_USEDEP}]
+               dev-python/pytest-subtesthack[${PYTHON_USEDEP}]
+       )"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )
+
+python_test() {
+       # skip tests needing servers running
+       local -x DAV_SERVER=skip
+       local -x REMOTESTORAGE_SERVER=skip
+       # pytest dies hard if the envvars do not have any value...
+       local -x CI=false
+       local -x DETERMINISTIC_TESTS=false
+       py.test -v || die "Tests fail with ${EPYTHON}"
+}