Add x11-apps/inputplug
authorStefan Huber <shuber@sthu.org>
Tue, 24 Jun 2014 14:11:19 +0000 (16:11 +0200)
committerStefan Huber <shuber@sthu.org>
Tue, 24 Jun 2014 14:29:40 +0000 (16:29 +0200)
x11-apps/inputplug/Manifest [new file with mode: 0644]
x11-apps/inputplug/inputplug-0.2.ebuild [new file with mode: 0644]
x11-apps/inputplug/inputplug-9999.ebuild [new file with mode: 0644]
x11-apps/inputplug/metadata.xml [new file with mode: 0644]

diff --git a/x11-apps/inputplug/Manifest b/x11-apps/inputplug/Manifest
new file mode 100644 (file)
index 0000000..ce33583
--- /dev/null
@@ -0,0 +1,5 @@
+DIST inputplug-0.2.tar.bz2 6536 SHA256 46ce130c6c993610e148a34e8dcc0e24a33a45c98a27b8c3cf9c5c8569e5916a SHA512 c4a50341ff5948483812b971977968c2900a8ecbcc9172f6577df1d3639ab4b50ba0aeba264bf83376131b614db718a9f4a7a4f7df0a0889ba17172a40f78bcd WHIRLPOOL 8ef251dad6186e46b225a9c41aece15e57249d5c734fcfe9868fbe1ab42659e41e36a1019e1c9bdc1a4206ad63462e551303f10413c8e9e73ecb6f8952422cb5
+DIST inputplug-9999.tar.bz2 6536 SHA256 46ce130c6c993610e148a34e8dcc0e24a33a45c98a27b8c3cf9c5c8569e5916a SHA512 c4a50341ff5948483812b971977968c2900a8ecbcc9172f6577df1d3639ab4b50ba0aeba264bf83376131b614db718a9f4a7a4f7df0a0889ba17172a40f78bcd WHIRLPOOL 8ef251dad6186e46b225a9c41aece15e57249d5c734fcfe9868fbe1ab42659e41e36a1019e1c9bdc1a4206ad63462e551303f10413c8e9e73ecb6f8952422cb5
+EBUILD inputplug-0.2.ebuild 574 SHA256 11d2df88f9f0ab8ef78cf8b151681a3cb8905f9c14172a93da7e6eacdda08ad9 SHA512 90779832d417d556631c7bf261b45c032043621f8eb0abe7c8d7117bd16994a7f5d68b65db3d672f944b37b028afc41049de46e92909793591ad2398a4684733 WHIRLPOOL c043744f0704d04cbb2300a7a9b7ca1a457c12b44129de4555dc30a2bf441035eb41b84f7f08e9627d5e0cf320b567c5e74da7a96434110e5e74f54a026b7572
+EBUILD inputplug-9999.ebuild 574 SHA256 11d2df88f9f0ab8ef78cf8b151681a3cb8905f9c14172a93da7e6eacdda08ad9 SHA512 90779832d417d556631c7bf261b45c032043621f8eb0abe7c8d7117bd16994a7f5d68b65db3d672f944b37b028afc41049de46e92909793591ad2398a4684733 WHIRLPOOL c043744f0704d04cbb2300a7a9b7ca1a457c12b44129de4555dc30a2bf441035eb41b84f7f08e9627d5e0cf320b567c5e74da7a96434110e5e74f54a026b7572
+MISC metadata.xml 314 SHA256 84a7319fae6597800b3a3d51c2df925f26bbc119dec41926bc30f8b9e27994e1 SHA512 50db0dab0d4faf777650e77b29389f1ef423f5605b983771fcae2111107a4a16e0f87454b2413a7c2d2743c3c62879c70f9be114e812aab1e4dce17d9dcd8ef9 WHIRLPOOL c7fbc0956d648b939a23a3a09e516d78e32f04895d0b69b2449f70f998dc10db397066ae043d1fe261b4647650d7f64bbebbd5d73eab148d00e37709b6f6cd92
diff --git a/x11-apps/inputplug/inputplug-0.2.ebuild b/x11-apps/inputplug/inputplug-0.2.ebuild
new file mode 100644 (file)
index 0000000..f14e7dd
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="A daemon monitoring XInput events"
+HOMEPAGE="https://bitbucket.org/andrew_shadura/inputplug/overview"
+SRC_URI="http://bitbucket.org/andrew_shadura/inputplug/get/tip.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="
+       x11-libs/libXi
+       x11-libs/libX11
+       "
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+       default_src_unpack
+       mv andrew_shadura-inputplug-* ${P}
+}
+
+src_install() {
+       dobin ${PN}
+       doman ${PN}.1
+}
diff --git a/x11-apps/inputplug/inputplug-9999.ebuild b/x11-apps/inputplug/inputplug-9999.ebuild
new file mode 100644 (file)
index 0000000..f14e7dd
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="A daemon monitoring XInput events"
+HOMEPAGE="https://bitbucket.org/andrew_shadura/inputplug/overview"
+SRC_URI="http://bitbucket.org/andrew_shadura/inputplug/get/tip.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="
+       x11-libs/libXi
+       x11-libs/libX11
+       "
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+       default_src_unpack
+       mv andrew_shadura-inputplug-* ${P}
+}
+
+src_install() {
+       dobin ${PN}
+       doman ${PN}.1
+}
diff --git a/x11-apps/inputplug/metadata.xml b/x11-apps/inputplug/metadata.xml
new file mode 100644 (file)
index 0000000..b10c3c7
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>shuber@sthu.org</email>
+               <name>Stefan Huber</name>
+       </maintainer>
+       <longdescription lang="en">
+               A daemon monitoring XInput events
+       </longdescription>
+</pkgmetadata>