Add app-pda/{ifuse,libimobiledevice}-9999
authorStefan Huber <shuber@sthu.org>
Sat, 29 Jul 2017 15:02:43 +0000 (17:02 +0200)
committerStefan Huber <shuber@sthu.org>
Sat, 29 Jul 2017 15:02:43 +0000 (17:02 +0200)
app-pda/ifuse/Manifest [new file with mode: 0644]
app-pda/ifuse/ifuse-9999.ebuild [new file with mode: 0644]
app-pda/libimobiledevice/Manifest [new file with mode: 0644]
app-pda/libimobiledevice/libimobiledevice-9999.ebuild [new file with mode: 0644]

diff --git a/app-pda/ifuse/Manifest b/app-pda/ifuse/Manifest
new file mode 100644 (file)
index 0000000..92fe4bc
--- /dev/null
@@ -0,0 +1,2 @@
+DIST ifuse.zip 22626 SHA256 ba21862b9735e9148345b3e1291b61f7f572d1377ca07f8c1fc1f7edfbbb3b39 SHA512 5f9f9c0ff6d9201e4c6de3d13391c64a75e34a073595977002aac89ccd9fdbba538e062ade3f6652201b25926f7ed9386841061423e4b1e8f39a135e0cb1500d WHIRLPOOL 872a0f5fb3f426ca53ee629913626d00a4d58ca0261663f7615d70dcef1cff8db8abb4634d6df08aab595d4f267c2a479c799569b9949be076ed8a06ec23a138
+EBUILD ifuse-9999.ebuild 918 SHA256 4de487bc436984996a32e3365365e643eb04d87c406d0ef7b2d25fc0eb7b6cbc SHA512 8afc6f4ee0e4cb02a2207bdc061c69bb23b0c72c62a6ac7874c638d57427086957865d942a4bbb771f2b467801f35c2733952acb6f4a4910bd270013a3b24dbd WHIRLPOOL 79a9d66c550afeb0381e043c14c56a56d8d7c36d77bebf30cba7a54e77150bfba2e5677eefa448e7776fac657867c31bbc921c9dd3e2d4845ea29a511e306d1b
diff --git a/app-pda/ifuse/ifuse-9999.ebuild b/app-pda/ifuse/ifuse-9999.ebuild
new file mode 100644 (file)
index 0000000..38d58c9
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools readme.gentoo
+
+DESCRIPTION="Mount Apple iPhone/iPod Touch file systems for backup purposes"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="https://github.com/libimobiledevice/${PN}/archive/master.zip -> ${PN}.zip"
+
+
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=app-pda/libimobiledevice-1.1.4:=
+       >=app-pda/libplist-1.8:=
+       >=sys-fs/fuse-2.7.0"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+DOCS="AUTHORS NEWS README"
+
+DOC_CONTENTS="Only use this filesystem driver to create backups of your data.
+The music database is hashed, and attempting to add files will cause the
+iPod/iPhone to consider your database unauthorised.
+It will respond by wiping all media files, requiring a restore through iTunes."
+
+S="${WORKDIR}/${PN}-master"
+
+src_prepare() {
+       eautoreconf
+}
diff --git a/app-pda/libimobiledevice/Manifest b/app-pda/libimobiledevice/Manifest
new file mode 100644 (file)
index 0000000..ff58c73
--- /dev/null
@@ -0,0 +1,3 @@
+AUX gnutls-3.4.patch 2415 SHA256 d83bf5e231fd2255800ddda9b0fc546d6f49abcd447fc9f2a40bca6ab1058028 SHA512 d1a46062d3e4a37dfbb8d8ac754f7e927e0f8f2720152d7f8604667b65ea8fa5f26777f4490cb01c7dc01771a96c545bc1b1c8b433482ad24fb9840f063fb36b WHIRLPOOL 8d6324cdef665f0871f801f50030d179639558876a00be34f53db0ef819c4ca29b5aa1ef4866d9f1d7babdb03bf29a7b2f7e3aa204632e01d9bc1fceceaf4891
+DIST libimobiledevice.zip 368476 SHA256 0db89a42d32f5476d2d0e062d7a6087136d73e9a2e0f3c5d0d32549397834093 SHA512 8f12a1803c412f12fea0ebaaa7d2c210f047a768509f1d80595003517b94a271d089e9796e9924d18783bee01c200447fd3315b0122e21283587e2157ec799b3 WHIRLPOOL 09353f5d3342cab3cc011e573e5b75d1f31120575da9ee1c437ae68ffb69de3d7c4c729ed3b4639f0e2a9c7381f565a157215cfeb7f4ac83701beb5f4dcac4c1
+EBUILD libimobiledevice-9999.ebuild 2549 SHA256 533b166802befde5008390b1b4f703194596e2485779448a3a49f3e96c03594a SHA512 a241188e1b92f968fae731cc7e49394e74fb5efc756cbe916690d8166ab19a3d9deaab2c6955efc756fd990646df51b14fde785677a407700c7176df3d6b3df0 WHIRLPOOL 40a49893580882ba0502daabd90cb1347294082c3c986bef52cc8b06958272d935fc09a67d677f502164537e6d8982277e08c473ad5f84509fc28072276b6a8e
diff --git a/app-pda/libimobiledevice/libimobiledevice-9999.ebuild b/app-pda/libimobiledevice/libimobiledevice-9999.ebuild
new file mode 100644 (file)
index 0000000..8a7be29
--- /dev/null
@@ -0,0 +1,101 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit eutils autotools python-r1
+
+DESCRIPTION="Support library to communicate with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="https://github.com/libimobiledevice/${PN}/archive/master.zip -> ${PN}.zip"
+
+# While COPYING* doesn't mention 'or any later version', all the headers do, hence use +
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/6" # based on SONAME of libimobiledevice.so
+KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86"
+IUSE="gnutls python static-libs"
+
+RDEPEND=">=app-pda/libplist-1.11:=
+       >=app-pda/libusbmuxd-1.0.9:=
+       gnutls? (
+               dev-libs/libgcrypt:0
+               >=dev-libs/libtasn1-1.1
+               >=net-libs/gnutls-2.2.0
+               )
+       !gnutls? ( dev-libs/openssl:0 )
+       python? (
+               ${PYTHON_DEPS}
+               app-pda/libplist[python(-),${PYTHON_USEDEP}]
+               )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       python? ( >=dev-python/cython-0.17[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( AUTHORS NEWS README )
+
+BUILD_DIR="${S}_build"
+S="${WORKDIR}/${PN}-master"
+
+src_prepare() {
+       #epatch "${FILESDIR}/gnutls-3.4.patch"
+       eautoreconf
+}
+
+src_configure() {
+       local ECONF_SOURCE=${S}
+
+       local myeconfargs=( $(use_enable static-libs static) )
+       use gnutls && myeconfargs+=( --disable-openssl )
+
+       do_configure() {
+               mkdir -p "${BUILD_DIR}" || die
+               pushd "${BUILD_DIR}" >/dev/null || die
+               econf "${myeconfargs[@]}" "${@}"
+               popd >/dev/null || die
+       }
+
+       do_configure_python() {
+               # Bug 567916
+               PYTHON_LDFLAGS="$(python_get_LIBS)" do_configure "$@"
+       }
+
+       do_configure --without-cython
+       use python && python_foreach_impl do_configure_python
+}
+
+src_compile() {
+       python_compile() {
+               emake -C "${BUILD_DIR}"/cython -j1 \
+                       VPATH="${S}/cython:${native_builddir}/cython" \
+                       imobiledevice_la_LIBADD="${native_builddir}/src/libimobiledevice.la"
+       }
+
+       local native_builddir=${BUILD_DIR}
+       pushd "${BUILD_DIR}" >/dev/null || die
+       emake -j1
+       use python && python_foreach_impl python_compile
+       popd >/dev/null || die
+}
+
+src_install() {
+       python_install() {
+               emake -C "${BUILD_DIR}/cython" -j1 \
+                       VPATH="${S}/cython:${native_builddir}/cython" \
+                       DESTDIR="${D}" install
+       }
+
+       local native_builddir=${BUILD_DIR}
+       pushd "${BUILD_DIR}" >/dev/null || die
+       emake -j1 DESTDIR="${D}" install
+       use python && python_foreach_impl python_install
+       popd >/dev/null || die
+
+       #dodoc docs/html/*
+       if use python; then
+               insinto /usr/include/${PN}/cython
+               doins cython/imobiledevice.pxd
+       fi
+       prune_libtool_files --all
+}