Add net-im/teams-bin
authorStefan Huber <shuber@sthu.org>
Wed, 18 Mar 2020 22:14:43 +0000 (23:14 +0100)
committerStefan Huber <shuber@sthu.org>
Wed, 18 Mar 2020 22:14:43 +0000 (23:14 +0100)
Taken from jorgicio overlay.

net-im/teams-bin/Manifest [new file with mode: 0644]
net-im/teams-bin/metadata.xml [new file with mode: 0644]
net-im/teams-bin/teams-bin-1.3.00.958.ebuild [new file with mode: 0644]

diff --git a/net-im/teams-bin/Manifest b/net-im/teams-bin/Manifest
new file mode 100644 (file)
index 0000000..825ab12
--- /dev/null
@@ -0,0 +1,3 @@
+DIST teams_1.3.00.958_amd64.deb 65064414 BLAKE2B 4f8788f7a9d3a2cc032e873453469dd3f2a5bd9dd43c60de4b8719e7fafcf903bf266b35b2da16c593005fa1a4dc275bc65cc6164654b0df909a564ddc4cc00e SHA512 ee698784a0c91346306466a1b794c4d1b4ff01ede2869cc7c4731e62ebf16e6f18b65aa0b03452c1011ddd5c654808f1725f62a62a43814cacb9d7a2934fb7c3
+EBUILD teams-bin-1.3.00.958.ebuild 830 BLAKE2B d9cac9084e4e925946d62375dc1b1a513c61f37c53290d27df19775639cb909042d6fff4f469fa66f69fd03714c20c8bf899915bb50c70a0c0f1371e4f1bfc05 SHA512 2538a61bc61925c09a343329ba27fc16d4fbf299b7e5ed997768db754f433eb8fed0ae3f58da70494cd998d727474c7a2437502ed569a2f94df081b344e666ae
+MISC metadata.xml 401 BLAKE2B e0498c534d965b5913439c8d0d40abc421f00898c373e1e23ec9eed75948e750db71b6bc5adf701617083cfd3e268e1422415476949ebdab4aeb8c51d13332e0 SHA512 093258cbf6e843a9b7453eacae297ca19c0610134dde17e26bf80dba8e6789f6eed3705b1be61dc24db5424c63ee0406ba37c547dcba3e67d77c01779cd1771e
diff --git a/net-im/teams-bin/metadata.xml b/net-im/teams-bin/metadata.xml
new file mode 100644 (file)
index 0000000..1e6f697
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>jpizarrocallejas@gmail.com</email>
+               <name>Jorge Pizarro Callejas</name>
+               <description>Jorgicio Gentoo Overlay</description>
+       </maintainer>
+       <use>
+               <flag name="pax_kernel">Triggers a paxmarking of the binary</flag>
+       </use>
+</pkgmetadata>
diff --git a/net-im/teams-bin/teams-bin-1.3.00.958.ebuild b/net-im/teams-bin/teams-bin-1.3.00.958.ebuild
new file mode 100644 (file)
index 0000000..968bc2f
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker xdg
+
+MY_PN="${PN/-bin}"
+
+DESCRIPTION="Microsoft Teams for Linux is your chat-centered workspace in Office 365"
+HOMEPAGE="https://teams.microsoft.com/downloads"
+SRC_URI="
+       amd64? ( https://packages.microsoft.com/repos/ms-${MY_PN}/pool/main/${PN:0:1}/${MY_PN}/${MY_PN}_${PV}_amd64.deb )"
+
+LICENSE="Ms-PL"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror strip"
+
+RDEPEND="
+       app-crypt/libsecret
+       dev-libs/nss
+       media-libs/alsa-lib
+       >=sys-libs/glibc-2.28-r4
+       x11-libs/gtk+:3
+       x11-libs/libXScrnSaver
+       x11-libs/libXtst
+       !net-im/teams"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+       unpack_deb "${A}"
+}
+
+src_prepare() {
+       rm _gpgorigin || die
+       default
+}
+
+src_install() {
+       mkdir -p "${ED}"
+       cp -r . "${ED}/"
+}