Remove dev-tex/latexmk
authorStefan Huber <shuber@sthu.org>
Mon, 6 Apr 2015 16:28:21 +0000 (18:28 +0200)
committerStefan Huber <shuber@sthu.org>
Mon, 6 Apr 2015 16:28:21 +0000 (18:28 +0200)
dev-tex/latexmk/Manifest [deleted file]
dev-tex/latexmk/files/completion.bash-2 [deleted file]
dev-tex/latexmk/latexmk-430.ebuild [deleted file]

diff --git a/dev-tex/latexmk/Manifest b/dev-tex/latexmk/Manifest
deleted file mode 100644 (file)
index 6b624ec..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-AUX completion.bash-2 1538 SHA256 f6949d450638d1be147bf5ece9488fd9445ffe47244c27643ff2a5df42aa1905 SHA512 dc43e1774d5a33b354eaa34f2812da58525a0fd8ef10db87e66f408bbe63666c1a4743582fbcc13efd61de5e50240af97da76f33614e32a7ab08a02338cac857 WHIRLPOOL 68ee714b78169d542d483cea831a271d0af4a5d1c6059f552bd029f20d4c29c00fde04e65cc49dade4d6bd10bbaf2e4adfe4dcb40feebc651062d7e08a8926a1
-DIST latexmk-430.zip 348721 SHA256 f5a2980cb81973e0b72ac629f9c8e2dd1761a13cddb44c06eeaf5113344864a8
-EBUILD latexmk-430.ebuild 922 SHA256 346fe7a8c3d3befe79394e5aee164b13263b97d50fab5041ace83cdc19353ca0 SHA512 d28e787c2ea7ef687f909925718deb2afce254e620204ad3c45f1d10dc16d0383f45cb80e31b94d8b04adf4ddfe9d9ff183c126b9259132a824e237d1f9d0b35 WHIRLPOOL 8c377209ac96dedd8c924884ad17a413c6c674d9675de01da97f6536b07eb73c280e1a95d575b1e3035e403dc467c0276320663f502ede4d8bbb35647b685136
diff --git a/dev-tex/latexmk/files/completion.bash-2 b/dev-tex/latexmk/files/completion.bash-2
deleted file mode 100644 (file)
index a24b7a8..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-#! /bin/bash
-
-#   This program is free software; you can redistribute it and/or modify
-#   it under the terms of the GNU General Public License as published by
-#   the Free Software Foundation; either version 2, or (at your option)
-#   any later version.
-
-# bash_completion for latexmk
-#
-#
-# Author:  Christoph Junghans
-#          ottxor@gentoo.org
-#
-# Revision history:
-#  0.1   26-05-10 --- initial version
-#  0.2   15-02-11 --- clean up
-#
-# HOWTO:
-# source this file to enable it
-
-_latexmk()
-{
-  local cur output aopts opts prev
-  cur=${COMP_WORDS[COMP_CWORD]}
-  prev=${COMP_WORDS[COMP_CWORD-1]}
-
-  output=$( $1 -help 2> /dev/null)
-  #options with args ,pattern: ^   (-XXX) <YYYY>.*$
-  aopts=" $( echo " $output" | sed -n 's/^[[:space:]]\+\(-[^[:space:]]\+\)[[:space:]]\+<[^>]\+>.*$/\1/p' | sort -u | tr '\n' ' ')"
-  #if previous option in in $aopts
-  if [[ -n "$prev" ]] && [[ -z "${aopts//* $prev *}" ]]; then
-    #argument of $prev ,pattern: ^ -XXX (<YYYY>).*$
-    opts=$(echo "$output" | sed -n "s/^[[:space:]]\+$prev[[:space:]]\+\(<[^>]\+>\).*\$/\1/p")
-    COMPREPLY=( $( compgen -W '$opts' -- $cur ) )
-  elif [[ "$cur" == -* ]]; then
-    #all options, pattern: ^    (-XXX).*$
-    opts=$( echo "$output" | sed -n 's/^[[:space:]]\+\(-[^[:space:]]\+\).*$/\1/p'| sort -u )
-    COMPREPLY=( $( compgen -W '$opts' -- $cur ) )
-  else
-    #filenames *.tex and dirs, rest is done by '-o filenames' below
-    COMPREPLY=( $( eval compgen -f -X "!*.tex" -- ${cur} ) $( compgen -d -- $cur ) )
-  fi
-}
-
-complete -F _latexmk -o filenames latexmk
diff --git a/dev-tex/latexmk/latexmk-430.ebuild b/dev-tex/latexmk/latexmk-430.ebuild
deleted file mode 100644 (file)
index aae992f..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/latexmk/latexmk-427a.ebuild,v 1.2 2011/11/02 15:33:18 aballier Exp $
-
-EAPI=4
-
-inherit bash-completion-r1
-
-DESCRIPTION="Perl script for automatically building LaTeX documents."
-HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
-SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
-IUSE=""
-
-RDEPEND="virtual/latex-base
-       dev-lang/perl"
-DEPEND="${RDEPEND}
-       app-arch/unzip"
-
-S=${WORKDIR}
-
-src_install() {
-       newbin latexmk.pl latexmk
-       doman latexmk.1
-       dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt
-       dodoc -r example_rcfiles extra-scripts
-       newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
-}