Add media-gfx/ipe5toxml-9999
authorStefan Huber <shuber@sthu.org>
Mon, 6 Apr 2015 15:54:51 +0000 (17:54 +0200)
committerStefan Huber <shuber@sthu.org>
Mon, 6 Apr 2015 16:09:14 +0000 (18:09 +0200)
The ipe tools, like ipe5toxml, moved to github/otfried/ipe-tools.

media-gfx/ipe5toxml/Manifest
media-gfx/ipe5toxml/ipe5toxml-20051114.ebuild [deleted file]
media-gfx/ipe5toxml/ipe5toxml-9999.ebuild [new file with mode: 0644]

index ebdb34e1d522bc56f71ff9dc352dc547fd445532..eb36f8d330b5a9be2122a07da4b54beb45ff475b 100644 (file)
@@ -1,2 +1 @@
-DIST ipe5toxml-20051114.tar.gz 8627 SHA256 f08c7a1e4b9fff439d8102bc44e26c7cf3602d9aadb93266a20764d190f1dc69
-EBUILD ipe5toxml-20051114.ebuild 590 SHA256 ad1cdbff12df1262f7cac72dd165e8f56d0e614d8bc962134a173b9b4b4db1fe SHA512 1adf848c75c9ad70b66f87d239e2ee40ef5ff86ad7a938d5aa2eb9f866a3d7043c1ebf4d82d302975c36de9278c03651edfbd86625132e6adfe80e164280a500 WHIRLPOOL b97d589bda95182a6c7a1955af41748e3e97e26ae50e34236896cf1d08687b11b4fcd925d7fa14ef07053fb2f6f6f469b97e7b2d02943fe76b28cf1369ec3b9e
+EBUILD ipe5toxml-9999.ebuild 529 SHA256 cad9c395df2395bc27c271c7808fe937c08747ce811c88829065b19c92fc68c8 SHA512 86d73e0528f1fc2d257c949450f7583e1106231b360cbf13e18d084c6315b5802d992b520d1076a8f1e2a38c393ff706d8d9f7dd5a09b22550249788e0bc809f WHIRLPOOL 98f78c63b275c95750401c9e3566a374de8d2aefffd1ccb1eff7df57149690cd78546daa77c2f787a04675d42d0fd073338ce176248c12fb39873150633341ca
diff --git a/media-gfx/ipe5toxml/ipe5toxml-20051114.ebuild b/media-gfx/ipe5toxml/ipe5toxml-20051114.ebuild
deleted file mode 100644 (file)
index 814d008..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=3
-
-DESCRIPTION="Converts Ipe-5 files to Ipe-6 xml files"
-HOMEPAGE="http://ipe7.sourceforge.net/"
-SRC_URI="http://sourceforge.net/projects/ipe7/files/tools/${P}.tar.gz/download
-               -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="mirror"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_prepare() {
-       mv $WORKDIR/$PN $WORKDIR/$P
-}
-
-src_compile() {
-       emake || die
-}
-
-src_install() {
-       base=$WORKDIR/${P}
-       exeinto /usr/bin/
-       doexe $base/ipe5toxml
-}
-
-
diff --git a/media-gfx/ipe5toxml/ipe5toxml-9999.ebuild b/media-gfx/ipe5toxml/ipe5toxml-9999.ebuild
new file mode 100644 (file)
index 0000000..8fb2d5d
--- /dev/null
@@ -0,0 +1,34 @@
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=0
+
+inherit git-2
+
+DESCRIPTION="Converts Ipe-5 files to Ipe-6 files"
+HOMEPAGE="https://github.com/otfried/ipe-tools/tree/master/figtoipe"
+EGIT_REPO_URI="https://github.com/otfried/ipe-tools.git"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+BASEDIR="${WORKDIR}/${P}/ipe5toxml"
+
+src_compile() {
+       cd ${BASEDIR}
+       emake
+}
+
+src_install() {
+       cd ${BASEDIR}
+       exeinto /usr/bin/
+       doexe ipe5toxml
+}
+
+