Add media-video/obs-v4l2sink
authorStefan Huber <shuber@sthu.org>
Tue, 17 Mar 2020 16:35:31 +0000 (17:35 +0100)
committerStefan Huber <shuber@sthu.org>
Tue, 17 Mar 2020 16:35:31 +0000 (17:35 +0100)
media-video/obs-v4l2sink/Manifest [new file with mode: 0644]
media-video/obs-v4l2sink/obs-v4l2sink-0.1.0.ebuild [new file with mode: 0644]

diff --git a/media-video/obs-v4l2sink/Manifest b/media-video/obs-v4l2sink/Manifest
new file mode 100644 (file)
index 0000000..2139a9d
--- /dev/null
@@ -0,0 +1,3 @@
+DIST obs-studio-25.0.0-rc6.tar.gz 8327654 BLAKE2B a2879da1ff0fbefdfd62f764a955b5aad0226d398f80d719fc1d95f3cadc5b4fd8e4aa3f5867a91f8e0df4447a72d82cee18c14ee919e2967ee67d1cec2d68f5 SHA512 b5bec2051e5f1f48dd11caa9dbbbb45081332c117718ac52641452b7e6a908063f7aef19339a583d03a17dddb89619d0c56e8d5ea719ef2842fa75cb4ec6618f
+DIST obs-v4l2sink-0.1.0.tar.gz 13598 BLAKE2B 92175ac9f70de74c872dd235018258030943c815d4db9b955e36019acd4410032b8e3381e358a0bf1ca23733d8f9e99b3e708503d0a003f39b901a30e13162a4 SHA512 640a6f79c9948b421e91b313586bfd18064df2cbe824370c9690ed40b4629b28bf9aaf30d20760acfabbf4110363743f0b475512e112fb5fc8b8809d793b0d44
+EBUILD obs-v4l2sink-0.1.0.ebuild 1004 BLAKE2B c542e579407727b69142eb21682447f406c2aa5455daf50d79b0a21786566b7e6995597020fa825832e5b8b179678ce34113668ecd7628bae3a564cc93d7b798 SHA512 1ba52f2ea1f36f1f11f2f1cb2aed4b50ca31dfc836883ef600ddc29a69861239b7c557248e5894f23519b3daeb62498997c0f139ca365aba077e541bfc886bde
diff --git a/media-video/obs-v4l2sink/obs-v4l2sink-0.1.0.ebuild b/media-video/obs-v4l2sink/obs-v4l2sink-0.1.0.ebuild
new file mode 100644 (file)
index 0000000..d2e37e0
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils cmake-utils
+
+case ${PV} in
+9999)
+       inherit git-r3
+       KEYWORDS=""
+       EGIT_REPO_URI="git://github.com/CatxFish/obs-v4l2sink.git"
+       ;;
+*)
+       KEYWORDS="~amd64 ~x86"
+       SNAPSHOT_COMMIT=""
+       SRC_URI="https://github.com/CatxFish/obs-v4l2sink/archive/${PV}.tar.gz -> ${P}.tar.gz
+                        https://github.com/obsproject/obs-studio/archive/25.0.0-rc6.tar.gz -> obs-studio-25.0.0-rc6.tar.gz"
+       ;;
+esac
+
+DESCRIPTION="OBS studio plugin for output to v4l2 loopback device"
+HOMEPAGE="https://github.com/CatxFish/obs-v4l2sink"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       media-video/obs-studio
+       media-video/v4l2loopback
+"
+RDEPEND="${DEPEND}"
+#PATCHES="${FILESDIR}/lib64.patch"
+
+src_prepare() {
+       sed -i "s_/lib/_/$(get_libdir)/_" CMakeLists.txt
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DLIBOBS_INCLUDE_DIR="${WORKDIR}/obs-studio-25.0.0-rc6/libobs"
+       )
+       cmake-utils_src_configure 
+}