Add media-gfx/figtoipe-9999
authorStefan Huber <shuber@sthu.org>
Mon, 6 Apr 2015 15:48:55 +0000 (17:48 +0200)
committerStefan Huber <shuber@sthu.org>
Mon, 6 Apr 2015 16:09:14 +0000 (18:09 +0200)
The ipe tools, like figtoipe, moved to github/otfried/ipe-tools.

media-gfx/figtoipe/Manifest
media-gfx/figtoipe/figtoipe-20091205.ebuild [deleted file]
media-gfx/figtoipe/figtoipe-9999.ebuild [new file with mode: 0644]

index 1c0fd435992f738e052ea25f663ea488300a4744..230997592e92b3ebbee691caae78cc08fd2af7cd 100644 (file)
@@ -1,2 +1 @@
-DIST figtoipe-20091205.tar.gz 20192 SHA256 cb8526fbe10fed1592a42623ae0d7f0570b47569d9aebffb235ca1fb0c0b27b1
-EBUILD figtoipe-20091205.ebuild 583 SHA256 726422269247ecaff969b7dd8798cfd26580c36e86e598ecf8f890ca3b761ee5 SHA512 9cf65fbaba2b95b26fb6121093c7bef71ad470202528b6cf508edec4c29b020bd72a46b9e56dbd4d1f1938c59603264fcda7d718b3451dbbb30d9c43d6b72011 WHIRLPOOL c8b16593dd664152ba50ebaa6dc2542cf06cd40974442a566d140e6272c0599f71d8eb956e27d6cfaf19319c879df2c6fdb1fa4865773dff2eb50254a80e85a4
+EBUILD figtoipe-9999.ebuild 575 SHA256 be0bf3c51a055b8bbb5590555108245f51fafd148754b1cc2b30741623593f9d SHA512 8a3153c13f682184efb6ad3c05c051b9d816391df088f1e2159e19d47cf3b3db47ce4294d73f3ceaa944bd8cd682c5fb9ad82652b40cc3252254b71b9ef7807a WHIRLPOOL 6eebb31678b5c5bf776eb732fac6e32eca2433f35450a25c919273dd4d69b9b722f8e5160c1a3f5ee42412951411dffba742ee92b1b20136f42a40979e1d1c8f
diff --git a/media-gfx/figtoipe/figtoipe-20091205.ebuild b/media-gfx/figtoipe/figtoipe-20091205.ebuild
deleted file mode 100644 (file)
index b0bbfbf..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=3
-
-DESCRIPTION="Converts xfig files to Ipe xml files"
-HOMEPAGE="http://ipe7.sourceforge.net/"
-SRC_URI="http://sourceforge.net/projects/ipe7/files/tools/${P}.tar.gz/download
-               -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="mirror"
-IUSE=""
-
-DEPEND=">=media-gfx/ipe-7.0.0"
-RDEPEND="${DEPEND}"
-
-src_compile() {
-       emake || die
-}
-
-src_install() {
-       base=$WORKDIR/${P}
-       exeinto /usr/bin/
-       doexe $base/figtoipe
-       doman $base/figtoipe.1
-}
-
-
diff --git a/media-gfx/figtoipe/figtoipe-9999.ebuild b/media-gfx/figtoipe/figtoipe-9999.ebuild
new file mode 100644 (file)
index 0000000..7ee593f
--- /dev/null
@@ -0,0 +1,35 @@
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=0
+
+inherit git-2
+
+DESCRIPTION="Converts FIG files (xfig) to XML files (Ipe)"
+HOMEPAGE="https://github.com/otfried/ipe-tools/tree/master/figtoipe"
+EGIT_REPO_URI="https://github.com/otfried/ipe-tools.git"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-gfx/ipe-7.0.0"
+RDEPEND="${DEPEND}"
+
+BASEDIR="${WORKDIR}/${P}/figtoipe"
+
+src_compile() {
+       cd ${BASEDIR}
+       emake
+}
+
+src_install() {
+       cd ${BASEDIR}
+       exeinto /usr/bin/
+       doexe figtoipe
+       doman figtoipe.1
+}
+
+