Add dev-util/stack
authorStefan Huber <shuber@sthu.org>
Thu, 12 Dec 2013 14:14:31 +0000 (15:14 +0100)
committerStefan Huber <shuber@sthu.org>
Thu, 12 Dec 2013 14:14:31 +0000 (15:14 +0100)
dev-util/stack/Manifest [new file with mode: 0644]
dev-util/stack/stack-9999.ebuild [new file with mode: 0644]

diff --git a/dev-util/stack/Manifest b/dev-util/stack/Manifest
new file mode 100644 (file)
index 0000000..b5467d9
--- /dev/null
@@ -0,0 +1,2 @@
+DIST stack-master.zip 456456 SHA256 eac17c142ffc2b680898580882c705d9565fb9fdf31ced478c990b88b96fc1ee SHA512 7d32c21afe545c7f2960744cd91e6bff62f0985ca6140cd0f819e72a333edea06ae62e1880360a14ec1d7af18144a3409868f751e85091051f0bc07371af3805 WHIRLPOOL b63535874858ed72f0e37f4c6b0c430b3949428145604fe010517e20bf725c190f037349a071d868573583de231e9e795b8086f77d5ab407fa8c44794280e29f
+EBUILD stack-9999.ebuild 988 SHA256 a2a9d1f3c3dab7ed26fa1713f558ca27e52e3fef13c68ada37aec7f19865599e SHA512 15784247d5912326debfcc7ef4f9638b52e4894277c496ca01cb03c199c6221e6933b6cf3e7a7950e40856d73211f30818f417b394a4266b151219ec0b1af5aa WHIRLPOOL cb7972bb0d4f7bd90b2aad7f40c5886ee7be600fbed475a51c5b094758c9b9a487ec06e0153035539a65ebe7b6ee10b06e854ee543b28b9440ea90c7eae39b82
diff --git a/dev-util/stack/stack-9999.ebuild b/dev-util/stack/stack-9999.ebuild
new file mode 100644 (file)
index 0000000..2a42ce3
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="STACK is a static checker that detects unstable code in C/C++ programs"
+HOMEPAGE="http://css.csail.mit.edu/stack/"
+SRC_URI="https://github.com/xiw/stack/archive/master.zip -> stack-master.zip"
+S="${WORKDIR}/${PN}-master"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+       sys-devel/clang
+       >sys-devel/llvm-3.3.9999"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+       autoreconf -fvi
+       econf
+}
+
+src_install() {
+       default
+
+       dobin src/ncpu
+       dobin src/optck
+       dobin src/poptck
+       dobin test/stack-build
+
+       exeinto /usr/bin/stack
+       doexe test/arm-linux-gnueabi-g++
+       doexe test/arm-linux-gnueabi-gcc
+       doexe test/cc1
+       doexe test/gcc
+
+       into /usr/bin/stack
+       dosym ${DESTTREE}/gcc ${DESTTREE}/c++
+       dosym ${DESTTREE}/gcc ${DESTTREE}/cc
+       dosym ${DESTTREE}/gcc ${DESTTREE}/clang
+       dosym ${DESTTREE}/gcc ${DESTTREE}/clang++
+       dosym ${DESTTREE}/gcc ${DESTTREE}/g++
+}