Add dev-libs/sdformat-6.2.0-r1
authorStefan Huber <shuber@sthu.org>
Fri, 27 Mar 2020 21:16:35 +0000 (22:16 +0100)
committerStefan Huber <shuber@sthu.org>
Fri, 27 Mar 2020 21:16:43 +0000 (22:16 +0100)
Removes -DUSE_INTERNAL_URDF=OFF from configure to fix error according to
https://bugs.gentoo.org/652112

dev-libs/sdformat/Manifest [new file with mode: 0644]
dev-libs/sdformat/sdformat-6.2.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-libs/sdformat/Manifest b/dev-libs/sdformat/Manifest
new file mode 100644 (file)
index 0000000..ab03553
--- /dev/null
@@ -0,0 +1,2 @@
+DIST sdformat-6.2.0.tar.bz2 466373 BLAKE2B 67bbe429cbd9871493c29379563f0704b8a050eb8e80645d92a6dea47321e0853bfd4b8442893792a47d743d7b701add21b45fcb7dfd21b2747d43f3f4d19f68 SHA512 e81f0f73e628155ef929c6d7930611f02009a8a217a043e127506c1310ae892b846a8080906feb0932108e9cfa280f473573a5af5096b55b66619b2ac794b0d5
+EBUILD sdformat-6.2.0-r1.ebuild 913 BLAKE2B f373dd542d1eeffdf063e0b2c73bc75d03a446d8a06b8de90c08b68beec471e6eecd163a0df1fdf169b6fe77ecef2881bef86035d189c2da797429de1cbb5d3a SHA512 428e5bdf8c3a32a5258adda9657938cedcced2aea7d578ebec598a2bde3ea4c17af8d4d3adf3ae1a2979ef468c2e479e8564bb6dfd8e4be91bdda61c851f685a
diff --git a/dev-libs/sdformat/sdformat-6.2.0-r1.ebuild b/dev-libs/sdformat/sdformat-6.2.0-r1.ebuild
new file mode 100644 (file)
index 0000000..20a36e9
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Simulation Description Format (SDF) parser"
+HOMEPAGE="http://sdformat.org/"
+SRC_URI="http://osrf-distributions.s3.amazonaws.com/sdformat/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# subslot = libsdformat major
+SLOT="0/6"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+       >=dev-libs/urdfdom-1:=
+       dev-libs/tinyxml
+       dev-libs/boost:=
+       sci-libs/ignition-math:4=
+"
+DEPEND="${RDEPEND}
+       dev-lang/ruby:*
+       virtual/pkgconfig
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_configure() {
+       echo "set (CMAKE_C_FLAGS_ALL \"${CXXFLAGS} \${CMAKE_C_FLAGS_ALL}\")" > "${S}/cmake/HostCFlags.cmake"
+       sed -i -e "s/LINK_FLAGS_RELWITHDEBINFO \" \"/LINK_FLAGS_RELWITHDEBINFO \" ${LDFLAGS} \"/" cmake/DefaultCFlags.cmake || die
+       local mycmakeargs=(
+               "-DUSE_EXTERNAL_TINYXML=ON"
+       )
+       cmake-utils_src_configure
+}