app-backup/sitarba: Add 2.2
authorStefan Huber <shuber@sthu.org>
Fri, 15 May 2020 18:27:18 +0000 (20:27 +0200)
committerStefan Huber <shuber@sthu.org>
Fri, 15 May 2020 18:27:18 +0000 (20:27 +0200)
app-backup/sitarba/Manifest [new file with mode: 0644]
app-backup/sitarba/metadata.xml [new file with mode: 0644]
app-backup/sitarba/sitarba-2.2.ebuild [new file with mode: 0644]

diff --git a/app-backup/sitarba/Manifest b/app-backup/sitarba/Manifest
new file mode 100644 (file)
index 0000000..1a1fd5f
--- /dev/null
@@ -0,0 +1,2 @@
+DIST sitarba-2.2.tar.gz 9744 BLAKE2B 0154fd71e49b9131ca08aea6a952ded507a0982d614e3c6111a2048f128ee934eb49cc3df561378e7273b833d53606156ab30a7fda212dbea2a52931eb232135 SHA512 68d05f880815a16260f73a528615a784b0d31dcf726570e82a00b546cb8a56b65cf0a8cd2d599b8b1a69646fb2a7f53ed0ca5185d21dd2d66ff03e224b4b320c
+EBUILD sitarba-2.2.ebuild 538 BLAKE2B c44c3c63646a288baab967300887b62bf79afa1435a8a6b389b8511c5d4662d900ececfcfc28202f920b59bf2413bda8c07af7ceec9d6abedd641d995f206e62 SHA512 f5a415567a34464b85d1fc617e56ce371bc59119d72dbd4819aefcbe78c2eae95d1125ad9b99521858dbfea3aab0b3dbdc07c906b308a70674a0f9f43c827c2f
diff --git a/app-backup/sitarba/metadata.xml b/app-backup/sitarba/metadata.xml
new file mode 100644 (file)
index 0000000..9434230
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>shuber@sthu.org</email>
+               <name>Stefan Huber</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/app-backup/sitarba/sitarba-2.2.ebuild b/app-backup/sitarba/sitarba-2.2.ebuild
new file mode 100644 (file)
index 0000000..1733ea4
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A simple tar-based backup tool"
+HOMEPAGE="https://www.sthu.org/code/sitarba.html"
+SRC_URI="http://git.sthu.org/?p=${PN}.git;a=snapshot;h=v${PV};sf=tgz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="mirror"
+
+DEPEND="
+       >=dev-lang/python-3.2
+       app-arch/tar
+       "
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}-v${PV}-09e6373"
+
+src_install() {
+       dobin sitarba
+       doman sitarba.1
+       dodoc sitarba.conf
+}