adding ipe-7.0.11
authorStefan Huber <shuber2@gmail.com>
Sun, 14 Nov 2010 20:34:44 +0000 (21:34 +0100)
committerStefan Huber <shuber2@gmail.com>
Sun, 14 Nov 2010 20:34:44 +0000 (21:34 +0100)
media-gfx/ipe/Manifest
media-gfx/ipe/files/ipe-beamer-install.patch [new file with mode: 0644]
media-gfx/ipe/ipe-7.0.11.ebuild [new file with mode: 0644]

index 5278b2b35741486ea162b5ed6ebac6aabbed9b16..40813af54a1a1db1b5490b35ce3bdecc23fede88 100644 (file)
@@ -1,2 +1,5 @@
+AUX ipe-beamer-install.patch 491 RMD160 729b8246faef227bde2742bcb47cf398f67dd7f7 SHA1 cd7f728ea8bde9abc31b8d723273d64e3de50a90 SHA256 70fc9f8526146893c33326e09677da564b26afa3d05f3860ed3c5e6ee07139a6
 DIST ipe-7.0.10-src.tar.gz 1158532 RMD160 1d57d362de66a5e718baf80ef79a6681ee48e046 SHA1 dc18230bb669b759b132c66440d99596b52fb833 SHA256 f343493d9e4d2390a9fdd5403162d187dd6ec1b204e7c026baec76657f40cd9c
+DIST ipe-7.0.11-src.tar.gz 1164684 RMD160 472396a1835151d12ca8ae68991223147693d448 SHA1 fba0a36b9c3c6989847d1a41a98c9798dc56ebce SHA256 c82f4dc539919d901d6d628bd606fc3803c57833ecf89b97a0829d46f62eb296
 EBUILD ipe-7.0.10.ebuild 2056 RMD160 c5ad5b0002cf557670353aec0bb9566253e35de2 SHA1 ce30d826bab989f4b6129cbe41a90a9cfddd376d SHA256 e0a1207c5f471cdded798cbeadc748f19805ce57adf9c3a6766785457a71e0ac
+EBUILD ipe-7.0.11.ebuild 2151 RMD160 efa0572614c976afd540d2d8bff86b6f9caf61b8 SHA1 318bd43ec5e166bc1bf62a88f2f9f0c0fc36beff SHA256 363cfc1759dedbeb1c49eb27e4fcf9aa0a6e6e3cc2258e85ff7f9dfa5fd51204
diff --git a/media-gfx/ipe/files/ipe-beamer-install.patch b/media-gfx/ipe/files/ipe-beamer-install.patch
new file mode 100644 (file)
index 0000000..570f7de
--- /dev/null
@@ -0,0 +1,10 @@
+--- ipe/Makefile       2010-11-14 21:17:55.977000084 +0100
++++ ipe/Makefile       2010-11-14 21:18:18.010999882 +0100
+@@ -65,6 +65,7 @@
+       $(INSTALL_FILES) ../../styles/colors.isy $(INSTALL_ROOT)$(IPESTYLES)\r
+       $(INSTALL_FILES) ../../styles/presentation.isy \\r
+                        $(INSTALL_ROOT)$(IPESTYLES)\r
++      $(INSTALL_FILES) ../../styles/beamer.isy $(INSTALL_ROOT)$(IPESTYLES)\r
+       $(INSTALL_FILES) icons/*.png $(INSTALL_ROOT)$(IPEICONDIR)\r
\r
+ # --------------------------------------------------------------------\r
diff --git a/media-gfx/ipe/ipe-7.0.11.ebuild b/media-gfx/ipe/ipe-7.0.11.ebuild
new file mode 100644 (file)
index 0000000..913105d
--- /dev/null
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+inherit eutils toolchain-funcs qt4-r2
+
+DESCRIPTION="A drawing editor which creates figures for inclusion in LaTeX documents and makes PDF presentations."
+HOMEPAGE="http://ipe7.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ipe7/ipe/${P}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror"
+IUSE="seamonkey"
+
+DEPEND="
+       app-text/texlive-core
+       >=dev-lang/lua-5.1
+       >=media-libs/freetype-2.1.8
+       sys-libs/zlib
+       >=x11-libs/cairo-1.8.0
+       >=x11-libs/qt-core-4.5:4
+       >=x11-libs/qt-gui-4.5:4
+       "
+
+RDEPEND="${DEPEND}
+       !seamonkey? ( || ( www-client/firefox
+               www-client/firefox-bin ) )
+       seamonkey? ( || ( www-client/seamonkey
+               www-client/seamonkey-bin ) )"
+
+S=${S}/src
+
+search_urw_fonts() {
+       local texmfdist="$(kpsewhich -var-value=TEXMFDIST)"     # colon-separated list of paths
+       local urwdir=fonts/type1/urw    # according to TeX directory structure
+       local IFS="${IFS}:"             # add colon as field separator
+       for dir in ${texmfdist}; do
+               if [[ -d "${dir}/${urwdir}" ]]; then
+                       URWFONTDIR="${dir}/${urwdir}"
+                       return 0
+               fi
+       done
+
+       return 1
+}
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-beamer-install.patch
+}
+
+pkg_setup() {
+       if search_urw_fonts; then
+               einfo "URW fonts found in ${URWFONTDIR}."
+       else
+               ewarn "Could not find directory containing URW fonts.  Ipe will not"
+               ewarn "function properly without them."
+       fi
+}
+
+src_compile() {
+       # Ipe's default browser is Firefox
+       local myconf
+       use seamonkey && myconf="IPEBROWSER=seamonkey"
+       # fix detection of lua
+       sed -i -e 's/lua5.1/lua/g' config.mak || die
+       # don't strip installed binaries
+       sed -i -e 's/install -s/install/' common.mak || die
+       # use moc instead of moc-qt4
+       sed -i -e 's/moc-qt4/moc/' config.mak || die
+
+       # -j1, since there are no deps in the Makefiles on libipe
+       emake -j1 CXX=$(tc-getCXX) $myconf IPEPREFIX="/usr" \
+               IPEDOCDIR="/usr/share/doc/${PF}" || die "emake failed"
+}
+
+src_install() {
+       emake install IPEPREFIX="/usr" IPEDOCDIR="/usr/share/doc/${PF}" \
+               INSTALL_ROOT="${D}" || die "emake install failed"
+       dodoc ../{news,readme}.txt || die
+}