x11-apps/inputplug: Add 0.3, fixes and EAPI=7
[shuber-gentoo-overlay.git] / x11-apps / inputplug / inputplug-9999.ebuild
index f14e7ddf7d476c38be092c5427e06e1d68e3984d..2c93113d8f4fb1f004aa8f7c2496cf6f7752c3de 100644 (file)
@@ -1,12 +1,17 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: $
 
-EAPI=5
+EAPI=7
 
-DESCRIPTION="A daemon monitoring XInput events"
-HOMEPAGE="https://bitbucket.org/andrew_shadura/inputplug/overview"
-SRC_URI="http://bitbucket.org/andrew_shadura/inputplug/get/tip.tar.bz2 -> ${P}.tar.bz2"
+DESCRIPTION="XInput event monitor daemon"
+HOMEPAGE="https://github.com/andrewshadura/inputplug"
+
+if [ "${PV}" == "9999" ]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/andrewshadura/${PN}"
+else
+       SRC_URI="https://github.com/andrewshadura/${PN}/archive/${PV}.tar.gz"
+fi
 
 LICENSE="MIT"
 SLOT="0"
@@ -15,15 +20,10 @@ IUSE=""
 
 DEPEND="
        x11-libs/libXi
-       x11-libs/libX11
+       x11-libs/libxcb
        "
 RDEPEND="${DEPEND}"
 
-src_unpack() {
-       default_src_unpack
-       mv andrew_shadura-inputplug-* ${P}
-}
-
 src_install() {
        dobin ${PN}
        doman ${PN}.1