x11-apps/inputplug: Add 0.3, fixes and EAPI=7
[shuber-gentoo-overlay.git] / x11-apps / inputplug / inputplug-0.3.ebuild
diff --git a/x11-apps/inputplug/inputplug-0.3.ebuild b/x11-apps/inputplug/inputplug-0.3.ebuild
new file mode 100644 (file)
index 0000000..2c93113
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="XInput event monitor daemon"
+HOMEPAGE="https://github.com/andrewshadura/inputplug"
+
+if [ "${PV}" == "9999" ]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/andrewshadura/${PN}"
+else
+       SRC_URI="https://github.com/andrewshadura/${PN}/archive/${PV}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="
+       x11-libs/libXi
+       x11-libs/libxcb
+       "
+RDEPEND="${DEPEND}"
+
+src_install() {
+       dobin ${PN}
+       doman ${PN}.1
+}