media-libs/libspiro: Add version 20200505
[shuber-gentoo-overlay.git] / media-libs / libspiro / libspiro-20200505.ebuild
diff --git a/media-libs/libspiro/libspiro-20200505.ebuild b/media-libs/libspiro/libspiro-20200505.ebuild
new file mode 100644 (file)
index 0000000..84d1bcd
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ -z ${PV%%*9999} ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/fontforge/${PN}.git"
+else
+       MY_PV="${PV}"
+       if [[ -z ${PV%%*_p*} ]]; then
+               inherit vcs-snapshot
+               MY_PV="8c7a31e"
+       fi
+       SRC_URI="
+               https://github.com/fontforge/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz
+       "
+       RESTRICT="primaryuri"
+       KEYWORDS="~amd64 ~x86"
+fi
+inherit autotools
+
+DESCRIPTION="A library for drawing beautiful curves"
+HOMEPAGE="https://github.com/fontforge/libspiro"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       default
+       eautoreconf
+}