media-gfx/svgtoipe: Switch to python-3.6
[shuber-gentoo-overlay.git] / media-gfx / svgtoipe / svgtoipe-9999.ebuild
index 358c973f05633ee4daded20676486d647b1b12c7..6f35cdf2d21554ddd83d1646c824f2addefaa568 100644 (file)
@@ -1,9 +1,10 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI=2
+EAPI=6
 
-inherit git-2
+PYTHON_COMPAT=( python3_6 )
+inherit git-r3 python-single-r1
 
 DESCRIPTION="Converts SVG files to Ipe xml files"
 HOMEPAGE="https://github.com/otfried/ipe-tools/tree/master/figtoipe"
@@ -15,13 +16,15 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE=""
 
-DEPEND="|| ( dev-lang/python:2.6[xml] dev-lang/python:2.7[xml] )"
+DEPEND="|| ( dev-lang/python:3.6[xml] )"
 RDEPEND="${DEPEND}"
 
 BASEDIR="${WORKDIR}/${P}/${PN}"
 
 src_install() {
        cd ${BASEDIR}
+       python_fix_shebang .
+
        mv ${PN}.py ${PN}
        exeinto /usr/bin/
        doexe ${PN}