Add media-gfx/svgtoipe-9999
[shuber-gentoo-overlay.git] / media-gfx / svgtoipe / svgtoipe-9999.ebuild
diff --git a/media-gfx/svgtoipe/svgtoipe-9999.ebuild b/media-gfx/svgtoipe/svgtoipe-9999.ebuild
new file mode 100644 (file)
index 0000000..2cd67ea
--- /dev/null
@@ -0,0 +1,31 @@
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit git-2
+
+DESCRIPTION="Converts SVG files to Ipe xml files"
+HOMEPAGE="https://github.com/otfried/ipe-tools/tree/master/figtoipe"
+EGIT_REPO_URI="https://github.com/otfried/ipe-tools.git"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="|| ( dev-lang/python:2.6[xml] dev-lang/python:2.7[xml] )
+               virtual/python-imaging"
+RDEPEND="${DEPEND}"
+
+BASEDIR="${WORKDIR}/${P}/ipe5toxml"
+
+src_install() {
+       cd ${BASEDIR}
+       mv svgtoipe.py svgtoipe
+       exeinto /usr/bin/
+       doexe svgtoipe
+}
+
+