Add media-gfx/svgtoipe-9999
[shuber-gentoo-overlay.git] / media-gfx / svgtoipe / svgtoipe-9999.ebuild
similarity index 55%
rename from media-gfx/svgtoipe/svgtoipe-20131107.ebuild
rename to media-gfx/svgtoipe/svgtoipe-9999.ebuild
index 6ec1b0e0416a7a0c0d53532cef5df2fb5209a4dd..2cd67ea38f4e4638e895f651f00a30f1a94c39a4 100644 (file)
@@ -1,29 +1,29 @@
-# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI=3
+EAPI=2
 
 
-DESCRIPTION="Converts svg files to Ipe xml files"
-HOMEPAGE="http://ipe7.sourceforge.net/"
-SRC_URI="http://sourceforge.net/projects/ipe7/files/tools/${P}.tar.gz/download
-               -> ${P}.tar.gz"
+inherit git-2
+
+DESCRIPTION="Converts SVG files to Ipe xml files"
+HOMEPAGE="https://github.com/otfried/ipe-tools/tree/master/figtoipe"
+EGIT_REPO_URI="https://github.com/otfried/ipe-tools.git"
+SRC_URI=""
 
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-RESTRICT="mirror"
 IUSE=""
 
 DEPEND="|| ( dev-lang/python:2.6[xml] dev-lang/python:2.7[xml] )
                virtual/python-imaging"
 RDEPEND="${DEPEND}"
 
 IUSE=""
 
 DEPEND="|| ( dev-lang/python:2.6[xml] dev-lang/python:2.7[xml] )
                virtual/python-imaging"
 RDEPEND="${DEPEND}"
 
+BASEDIR="${WORKDIR}/${P}/ipe5toxml"
 
 src_install() {
 
 src_install() {
-       cd $WORKDIR/${P}
+       cd ${BASEDIR}
        mv svgtoipe.py svgtoipe
        mv svgtoipe.py svgtoipe
-
        exeinto /usr/bin/
        doexe svgtoipe
 }
        exeinto /usr/bin/
        doexe svgtoipe
 }