Add media-gfx/pdftoipe-9999
[shuber-gentoo-overlay.git] / media-gfx / pdftoipe / pdftoipe-9999.ebuild
diff --git a/media-gfx/pdftoipe/pdftoipe-9999.ebuild b/media-gfx/pdftoipe/pdftoipe-9999.ebuild
new file mode 100644 (file)
index 0000000..dd0a6ef
--- /dev/null
@@ -0,0 +1,37 @@
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+
+EAPI=0
+
+inherit git-2
+
+DESCRIPTION="Converts PDF files to Ipe xml files"
+HOMEPAGE="https://github.com/otfried/ipe-tools/tree/master/figtoipe"
+EGIT_REPO_URI="https://github.com/otfried/ipe-tools.git"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-text/poppler"
+RDEPEND="${DEPEND}"
+
+BASEDIR="${WORKDIR}/${P}/pdftoipe"
+
+src_compile() {
+       cd ${BASEDIR}
+       emake
+}
+
+src_install() {
+       cd ${BASEDIR}
+       exeinto /usr/bin/
+       doexe pdftoipe
+       doman pdftoipe.1
+       dodoc readme.txt
+}
+
+