Add Ipe tools and change Ipe homepage
[shuber-gentoo-overlay.git] / media-gfx / pdftoipe / pdftoipe-20091014.ebuild
diff --git a/media-gfx/pdftoipe/pdftoipe-20091014.ebuild b/media-gfx/pdftoipe/pdftoipe-20091014.ebuild
new file mode 100644 (file)
index 0000000..09a085d
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+DESCRIPTION="Converts pdf files to Ipe xml files"
+HOMEPAGE="http://ipe7.sourceforge.net/"
+SRC_URI="http://sourceforge.net/projects/ipe7/files/tools/${P}.tar.gz/download
+               -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror"
+IUSE=""
+
+DEPEND="app-text/poppler
+       >=media-gfx/ipe-7.0.0"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+       emake || die
+}
+
+src_install() {
+       base=$WORKDIR/${P}
+       exeinto /usr/bin/
+       doexe $base/pdftoipe
+       doman $base/pdftoipe.1
+}
+
+