media-gfx/ipe: Add ipe-7.2.18
[shuber-gentoo-overlay.git] / media-gfx / ipe / ipe-7.2.17.ebuild
index 21a02f9cab46f735739ab537261874447cded2e2..245df823185d369d7d48572f18c17f6e1efabc7e 100644 (file)
@@ -1,7 +1,7 @@
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Header: $
 
-EAPI=4
+EAPI=7
 inherit eutils toolchain-funcs
 
 DESCRIPTION="Drawing editor for creating figures in PDF or PS formats"
@@ -15,7 +15,7 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="highprec"
 
-RDEPEND="app-text/texlive-core
+       RDEPEND="<app-text/texlive-2020
        >=dev-lang/lua-5.3
        media-libs/freetype:2
        x11-libs/cairo
@@ -52,9 +52,10 @@ src_prepare() {
        sed -i -e 's/install -s/install/' common.mak || die
 
        if use highprec; then
-               einfo "Adding patch for higher output precision"
-               epatch "${FILESDIR}"/${PN}-outputprecision.patch
+               eapply "${FILESDIR}"/${PN}-outputprecision.patch
        fi
+
+       eapply_user
 }
 
 pkg_setup() {