ipe-7.1.4: get rid of lua patches
[shuber-gentoo-overlay.git] / media-gfx / ipe / ipe-7.1.4.ebuild
index d97da85..c4d1a50 100644 (file)
@@ -53,8 +53,6 @@ src_prepare() {
                einfo "Adding patch for higher output precision"
                epatch "${FILESDIR}"/${PN}-outputprecision.patch
        fi
                einfo "Adding patch for higher output precision"
                epatch "${FILESDIR}"/${PN}-outputprecision.patch
        fi
-       epatch "${FILESDIR}"/0001-config.mak-use-correct-lua-package-name.patch
-       epatch "${FILESDIR}"/0002-config.mak-Add-ldl-flag.patch
 }
 
 pkg_setup() {
 }
 
 pkg_setup() {
@@ -70,7 +68,8 @@ src_compile() {
        emake \
                CXX=$(tc-getCXX) \
                IPEPREFIX="${EPREFIX}/usr" \
        emake \
                CXX=$(tc-getCXX) \
                IPEPREFIX="${EPREFIX}/usr" \
-               IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html"
+               IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html" \
+               LUA_PACKAGE=lua
 }
 
 src_install() {
 }
 
 src_install() {