adding ipe-7.1.4, fixing older ipe ebuilds
[shuber-gentoo-overlay.git] / media-gfx / ipe / ipe-7.1.3.ebuild
index b5c33aea4cc38bae4a686e394f8c3fc2dacca6f3..4c3a575c01262f9fc9f9319071ec3828a29aadd2 100644 (file)
@@ -41,13 +41,6 @@ search_urw_fonts() {
        return 1
 }
 
-src_prepare() {
-       if use highprec; then
-               einfo "Adding patch for higher output precision"
-               epatch "${FILESDIR}"/${PN}-outputprecision.patch
-       fi
-}
-
 pkg_setup() {
        if search_urw_fonts; then
                einfo "URW fonts found in ${URWFONTDIR}"
@@ -65,6 +58,10 @@ src_prepare() {
                config.mak || die
        sed -i -e 's/install -s/install/' common.mak || die
 
+       if use highprec; then
+               einfo "Adding patch for higher output precision"
+               epatch "${FILESDIR}"/${PN}-outputprecision.patch
+       fi
 }
 
 src_compile() {