adding ipe-7.1.4, fixing older ipe ebuilds
[shuber-gentoo-overlay.git] / media-gfx / ipe / ipe-7.1.2.ebuild
index 9e39b249e130c93aa6181c7efa5d95237f102c73..88fd1ab693bc1620af05115d8538b84593884c26 100644 (file)
@@ -41,13 +41,6 @@ search_urw_fonts() {
        return 1
 }
 
-src_prepare() {
-       if use highprec; then
-               einfo "Adding patch for higher output precision"
-               epatch "${FILESDIR}"/${PN}-outputprecision.patch
-       fi
-}
-
 pkg_setup() {
        if search_urw_fonts; then
                einfo "URW fonts found in ${URWFONTDIR}"
@@ -65,6 +58,10 @@ src_prepare() {
                config.mak || die
        sed -i -e 's/install -s/install/' common.mak || die
 
+       if use highprec; then
+               einfo "Adding patch for higher output precision"
+               epatch "${FILESDIR}"/${PN}-outputprecision.patch
+       fi
 }
 
 src_compile() {