adding ipe-7.1.4, fixing older ipe ebuilds
[shuber-gentoo-overlay.git] / media-gfx / ipe / ipe-7.1.2.ebuild
index 7e4f7ef246b75b7a8a24f8fe35ec2660ff7c8e5b..88fd1ab693bc1620af05115d8538b84593884c26 100644 (file)
@@ -1,4 +1,3 @@
-# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
@@ -12,7 +11,7 @@ SRC_URI="mirror://sourceforge/ipe7/${PN}/7.1.0/${P}-src.tar.gz"
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="highprec"
 
 RDEPEND="app-text/texlive-core
        dev-lang/lua
@@ -24,6 +23,7 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
 S="${WORKDIR}/${P}/src"
+COMMONDIR=/usr/share/ipe/common
 
 search_urw_fonts() {
        # colon-separated list of paths
@@ -58,6 +58,10 @@ src_prepare() {
                config.mak || die
        sed -i -e 's/install -s/install/' common.mak || die
 
+       if use highprec; then
+               einfo "Adding patch for higher output precision"
+               epatch "${FILESDIR}"/${PN}-outputprecision.patch
+       fi
 }
 
 src_compile() {
@@ -75,4 +79,17 @@ src_install() {
        dodoc ../{news,readme}.txt
        doicon ipe/icons/ipe.png
        make_desktop_entry ipe Ipe ipe
+       # Link style sheets
+       if [ -d $COMMONDIR/styles ]; then
+               einfo "Linking common style sheets from $COMMONDIR"
+               for f in $COMMONDIR/styles/*; do
+                       einfo "  Linking ${f##*/}"
+                       dosym $f usr/share/ipe/${PV}/styles/${f##*/}
+               done
+
+               elog "Style sheets from $COMMONDIR/styles have been symlinked to"
+               elog "the style sheet directory of ${P}. If you add additional"
+               elog "style sheets later to $COMMONDIR/styles you may symlink"
+               elog "them by hand to '/usr/share/ipe/${PV}/styles/'."
+       fi
 }