add pdftoipe-20110916
[shuber-gentoo-overlay.git] / media-gfx / ipe / ipe-7.0.13.ebuild
index 83a14b4dc9b85b761e9d2d33a40b9255448be5bb..a470b9030422475a465af6cf8bae5c9f8ca32883 100644 (file)
@@ -33,6 +33,8 @@ RDEPEND="${DEPEND}
                www-client/seamonkey-bin ) )"
 
 S=${S}/src
+COMMONDIR=/usr/share/ipe/common
+
 
 search_urw_fonts() {
        local texmfdist="$(kpsewhich -var-value=TEXMFDIST)"     # colon-separated list of paths
@@ -84,4 +86,19 @@ src_install() {
        emake install IPEPREFIX="/usr" IPEDOCDIR="/usr/share/doc/${PF}" \
                INSTALL_ROOT="${D}" || die "emake install failed"
        dodoc ../{news,readme}.txt || die
+
+       # Link style sheets
+       if [ -d $COMMONDIR/styles ]; then
+               einfo "Linking common style sheets from $COMMONDIR"
+               for f in $COMMONDIR/styles/*; do
+                       einfo "  Linking ${f##*/}"
+                       dosym $f usr/share/ipe/${PV}/styles/${f##*/}
+               done
+
+               elog "Style sheets from $COMMONDIR/styles have been symlinked to"
+               elog "the style sheet directory of ${P}. If you add additional"
+               elog "style sheets later to $COMMONDIR/styles you may symlink"
+               elog "them by hand to '/usr/share/ipe/${PV}/styles/'."
+       fi
 }
+