Add Ipe tools and change Ipe homepage
[shuber-gentoo-overlay.git] / media-gfx / figtoipe / figtoipe-20091205.ebuild
diff --git a/media-gfx/figtoipe/figtoipe-20091205.ebuild b/media-gfx/figtoipe/figtoipe-20091205.ebuild
new file mode 100644 (file)
index 0000000..b0bbfbf
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+DESCRIPTION="Converts xfig files to Ipe xml files"
+HOMEPAGE="http://ipe7.sourceforge.net/"
+SRC_URI="http://sourceforge.net/projects/ipe7/files/tools/${P}.tar.gz/download
+               -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror"
+IUSE=""
+
+DEPEND=">=media-gfx/ipe-7.0.0"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+       emake || die
+}
+
+src_install() {
+       base=$WORKDIR/${P}
+       exeinto /usr/bin/
+       doexe $base/figtoipe
+       doman $base/figtoipe.1
+}
+
+