media-gfx/cgal-ipelets: Add cgal-ipelets-5.2.2-r1
[shuber-gentoo-overlay.git] / media-gfx / cgal-ipelets / cgal-ipelets-5.2.2-r1.ebuild
diff --git a/media-gfx/cgal-ipelets/cgal-ipelets-5.2.2-r1.ebuild b/media-gfx/cgal-ipelets/cgal-ipelets-5.2.2-r1.ebuild
new file mode 100644 (file)
index 0000000..8d8fe2d
--- /dev/null
@@ -0,0 +1,27 @@
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=7
+
+CMAKE_BUILD_TYPE=Release
+
+inherit multilib cmake-utils
+
+MY_P=CGAL-${PV}
+
+DESCRIPTION="Ipe addons shipped with the CGAL library"
+HOMEPAGE="http://www.cgal.org/ https://gforge.inria.fr/projects/cgal/"
+SRC_URI="https://github.com/CGAL/cgal/releases/download/v${PV}/${MY_P}.tar.xz"
+
+LICENSE="LGPL-3 GPL-3 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+       media-gfx/ipe
+       ~sci-mathematics/cgal-${PV}
+       "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/demo/CGAL_ipelets"