gitweb tarballs without hash in subdir
[shuber-gentoo-overlay.git] / mail-mta / smailq / smailq-1.0.ebuild
index a4393f1acb601915b218e69484bce313f13b8240..4a689c53109debff2892dabec1eac7543ca73654 100644 (file)
@@ -1,17 +1,23 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI=5
+EAPI=7
 
 DESCRIPTION="A simple mail queue"
 HOMEPAGE="http://www.sthu.org/code/smailq.html"
-SRC_URI="http://git.sthu.org/?p=smailq.git;a=snapshot;h=v1.0;sf=tgz -> smailq-1.0.tar.gz"
-
 LICENSE="LGPL-3"
 SLOT="0"
-KEYWORDS="~x86 ~amd64"
-RESTRICT="mirror"
 IUSE="+mta"
+RESTRICT="mirror"
+
+if [ "${PV}" == "9999" ]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://git.sthu.org/repos/smailq.git"
+else
+       SRC_URI="http://git.sthu.org/?p=${PN}.git;a=snapshot;h=refs/tags/v${PV};sf=tgz -> ${P}.tar.gz"
+       KEYWORDS="~x86 ~amd64"
+       S="${WORKDIR}/${PN}-v${PV}"
+fi
 
 DEPEND="
        >=dev-lang/python-3.2
@@ -33,7 +39,6 @@ DEPEND="
        !>=mail-mta/ssmtp-2.64-r2[mta]
        "
 RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}-v1.0-6b48c59"
 
 
 src_install() {